Issue connecting wifi

Hey guys, I’m having trouble connecting the core to a wifi network but to no avail. It is flashing green and just cannot get it past that phase.

Here’s what I’ve tried:

  • I’ve done the firmware update dance (multiple times)
  • Set the Airport Extreme to channel 6, unencrypted
  • Tried a different wireless networks (including my phone)
  • Tried the iPhone app smart connect but it cannot find the device at all.

Any one have any suggestions that I can try?

Maybe you can try sending wifi credentials via USB instead :slight_smile:

Yeah, I’ve tried. Goes to flashing green and never finds it.

This is also me doing the updates:



This is my wireless setup:

Is it an entirely new core?

Can you try this patch instead: https://github.com/spark/spark-cli/raw/10f65d1eba553df807457a5b90388704ea14b2bf/js/binaries/cc3000-patch-programmer.bin

Also, your network needs to be 2.4Ghz for the router settings

Yea, it’s an entirely new core. But it was bought with the $99 bundle from Microcenter. Not sure if shelf life is a factor here. I put both to differentiate that the 5GHz and the 2.4GHz channels are completely separate.

Just applied that patch, with the spark_tinker.bin right afterwards:
MD5 (spark_tinker.bin) = e16448c3117a682b1192275e412c66d8
MD5 (cc3000-patch-programmer.bin) = a7c20f7e4f0c48c5a8c02cf591f2517d

Then did the spark setup wifi again and it worked! But for my understanding, can I know why that specific patch worked and not the other ones that I’ve tried?

HA! It’s just pure :fireworks:

I encountered the same issue recently trying to get some new cores online but the update CC3000 patch in Spark-cli doesn’t seem to work.

Performing a 1.29 patch first resolves the issue and using the 1.32 patch thereafter seems to be the method for patching.

Have filed an issue for this: https://github.com/spark/spark-cli/issues/133

1 Like

Holy crap! :flushed:

I just updated my spark-cli to test this new patch and you’ve brought my “defective” Core I haven’t been able to get online since I received it on Dec 17th back from the dead! You made my day! :grinning: