Unable to connect new Spark Core to WiFi [Solved via spark-cli 0.4.93]

I just received my Spark Core two days ago and have not had any success connecting to my home WiFi after 2 nights of effort. A rather disappointing intro to the IoT wave. :’(

I have not been able to get past flashing blue LED while using the iOS app and my regular home router. Then when I try the USB setup, the Spark never gets past flashing green.

My environment:

  • Core with Chip antenna
  • Using iPhone 5 power adapter connected to USB or USB port on my desktop
  • Router is current model Apple AirPort Extreme 802.11ac with out of the box settings. 2.4 and 5 GHz are active, and the router supports 802.11a/b/g/n/ac
  • WPA2 personal
  • Channel 6 (also tried 1)
  • About 4 feet from the router
  • SSID “Land of Ooo” (with spaces) but I tried activating a guest network with SSID “test” and that didn’t work either
  • Default is 10.0.0.x network but also tried 192.168.0.x

Tried many different ways recommended in troubleshooting steps here. Resetting/clearing Core memory, factory reset, USB setup, troubleshooting flow chart, etc.

Also tried USB setup while connecting to my phone wifi hotspot and no luck there either.

Tried an older Belkin router with iOS app and the LED light did change to flashing green but that was as far as it got. I really don’t want to cripple or complicate my network with this old router anyway though, even if it did work–but it didn’t anyway.

Last thing I tried was CC3000 flash using spark-cli, node.js, homebrew, dfu-util. I know it’s early in this space, but that was a lot of unexpected dependency chains to follow to get to that point!

After that I’m still unable to get it to get past flashing blue while using the AirPort network and iOS app nor past green while using USB setup.

Questions:

  1. Did the phone hotspot test prove it’s not the Airport router at fault? It didn’t get past flashing blue in this test either.
  2. Does anyone have Cores working with the latest AirPort Extreme
    802.11
  3. What do I try next? :frowning:

@ssstraub
Yes, I did get it to work with my airport extreme ac version.
Connected it to the computer via usb.
Put the device into WIFI setup mode (slow blinking blue light)
Opened the USB serial connection, via CoolTerm
Pressed 'w’
Carefully typed my SSID “Strathearn Manor” with capitals and space just like that.
Pressed Enter
It gave security options, I believe default is WPA2 which is option 3
Then carefully typed my password
Pressed Enter,

It worked for me very quickly.

Thanks. My plan to try tonight:

1.) connect your core via usb

2.) hold down both buttons and release the reset button, keep holding until your core flashes yellow

3.) update your factory reset version:
spark flash --factory tinker

4.) run the patch
spark flash --usb cc3000

5.) once your core stops flashing purple, and starts flashing yellow again, reload tinker
spark flash --usb tinker

6.) Plug your wifi credentials back in with:
spark setup wifi

@ssstraub
I have 3 cores and I’ve done this process to all 3 of them without fail.

Maybe defective core?
Did you try Holding Mode, tapping reset, Keep holding Mode till you see the white light flash quickly.
This Completely sets it back to default.

Are you trying to connect it to your Guest network? Could be an issue with DHCP? Guest does 10.1.1.# by default.
I changed my Airport to using 192.168.1.#

Is your password complicated? My password is just “password”.

Flashing green means the Wifi Credentials are wrong. (if it Just sits there)
I got mine to flash green when I put in the wrong ssid.

@ssstraub
I hold Mode till it flashes WHITE.

Yes did the reset to the quick flashing white light a few times.

I enabled the AirPort guest network only to test if that would work–I’ve since disabled it. My router is basically in out-of-the-box default state except that I now manually changed it to use 192.168.x.x addresses because I read on this site that Core doesn’t work with 10.0.x.x networks. (This seems like a major issue given the number of Apple routers in the wild that default to those addresses.)

The core works fine on 10.0.0.x addresses–I use it that way.

The Apple routers which I have and love, try very hard to promote all traffic to the 5GHz band and that doesn’t work for the core. If you switch off the 5GHz features on your router for testing, I think you will have better luck.

1 Like

Thanks, I will try temporarily turning off 5 GHz also tonight.

Well I did all 6 steps in the order listed above, plus tried giving my 5 GHz network a separate SSID (you cannot completely disable 5 GHz independently of 2.4 nor can you set the radio mode) and still no luck.

Also my WiFi password is a very simple string of numbers and letters. My Spark account password however is very complex as I used the auto generated one Safari gave me for now.

:’(

I also tried again my Belkin router connecting both via iOS app and spark-cli and neither are able to connect to the network.

Maybe my Core is defective?

I use Spark core with Airport Extreme in 2.4 and 5GHz configuration (SSID is different) and no problem at all. I might had to manually switch my iPhone to 2.4GHz to perform setup though, I don’t remeber (I have most of devices set to prefer 5GHz network due to 2.4GHz pollution in area I live in).

I’m starting to be more convinced it has a hardware problem, since I’ve tried effectively 3 different networks (AirPort, Belkin, iPhone hotspot) and none of them get past flashing green when connecting via USB with spark-cli even after I refreshed the firmware and tinker.

One other funny possibility that came up once before is to make sure you have a chip antenna core or if you do have a u.fl antenna core that you have properly plugged in a u.fl cable and antenna. There are pictures on the spark doc pages if you aren’t sure.

Yeah it’s definitely a chip antenna with the white bar at the end.

1 Like

Hoping to get a response from someone on the Spark team. Sent an email to hello@spark.io on Friday.

Found an even older b/g router and tried that and a different USB cable with no luck. I think the hardware is bad.

1 Like

Hi @ssstraub

Sounds like you need to send an email to hello@spark.io and ask for a replacement.

1 Like

My Core didn’t immediately connect to my Airport Express either. The Tinker app did see my network, but it never got the core setup. I did have to go through the USB & terminal setup. This is a bit concerning, because if I did make a “product”, it wouldn’t necessarily setup on customer networks automatically, right? Or am I thinking about this incorrectly?

The Photon coming in March will support 802.11n and “soft AP” which I hope to be a significantly better experience for the end user. That said the Core should still be fine for prototyping.

Back on topic: Still haven’t heard from anyone at Spark. :frowning: I know it’s the holidays… Just sucks that my whole vacation is going to be gone before I have a working Core to play with.

Received a replacement Core today and the connection via iOS app didn’t work but connection via Terminal with “spark setup” worked flawlessly the first time.

I guess this other Core is defective in some way…

Update: This core was brought back from the dead via spark-cli update 0.4.93! See the post here: https://github.com/spark/spark-cli/issues/133

I guess it was a software bug after all!

1 Like