New Spark Core flashes green with occasional solid cyan and won't connect to WiFi

Hi, looking for any ideas here. The Spark iOS app will let me type in wifi creds at ‘Let’s Connect your core’, but will sit on the little animation for a couple of minutes and then report ‘No cores found.’

I’ve followed the instructions at theta of this page: [Spark core] Common issues and they work ok, finishing with ‘Done! Your device should now restart.’

But the device keeps flashing, in a cycle of perhaps 60 seconds of green, followed by a second or so of flashing cyan. And it won’t appear in Build as a device.

I thought it might be my WiFi (it’s a work network I don’t control, and it has a space in the SSID) so I tried my iPhone’s Personal hotspot, and also a new wireless network from an Apple Airport Express (802.11b/g, no space in the SSID).

I’ve also tried the spark on a wall wart power supply.

Any ideas? Thanks! Joe

I won’t be buying any more of these things. It doesn’t work, and none of the troubleshooting guides have helped.

Maybe @corey from support could help out here! One last try?!?

1 Like

Any help welcomed. I’d love to get it working!

1 Like

@droit: are you positive you have a new “Spark Core” or a Photon?
If you send me your order number in a personal message on here, I can verify this for you.

Once I get that clarified, we should be able to solve your issue from there.

-Corey :smile:


Hi @corey,

I am running into the same issue with my Cores. They used to work just awesomely (CC3000 patch applied and all). I switched to using Photons and P1s for the past months and haven’t had a chance to use the Coressince then. I want to start some robotics project and would like to start utilizing the Cores again.

Today I tried to set them up with Wi-Fi but the Cores would just flash green for a long while, solid cyan for 1 second, then repeat flashing green (and hence forth). I am not sure if there is a Safe Mode I could use for the Core, like the P1s and Photons.

What information would you need for resolving this problem? Core IDs?

Let me know, thanks!

On the Cores (especially when not being updated recently) is no Safe Mode, but unlike the Photon the Core has a working Factory Reset.
Try this - maybe twice in a row, to make sure.

Just in case the device IDs got damaged or you detached the devices from your account, check the device IDs too (e.g. via CLI or serial monitor “i”)


Thanks for the advice. I’ve tried all those but was still stuck in the same situation. The device IDs were good, and the Cores were all claimed on my account.

I noticed that on the cloud build, my cores are being built with 0.3.4 firmware version. I don’t recall the Core having a firmware release like that. All my Photons and P1s are with 0.4.5 now. I couldn’t really find any firmware release notes on GitHub for the Cores aside from the old CC3000 patch.

Any ideas?

0.3.4 was released Oct. 2014 and on the Core you always have the system firmware delivered with your application firmware, so if you flashed after Oct. 2014 you definetly had 0.3.4 already.
The option to choose versions is a new feature (a few weeks now).

1 Like


are your Photon’s and P1’s able to connect to the same wifi network that your Core is failing to connect to?

Yes, WPA2 wifi network. This is what puzzles me so much. Both the Photons and the P1s connect very quickly to the cloud.

well they are newer, much better versions of the Core. However, that does not mean that the core shouldn’t be able to connect to wifi, as it is a wifi device.

looking into this now

1 Like