Spark core stuck in green light

Hi,
I can’t connect the core to the Wifi network, it gets stuck in green light forever. I tried using the USB connection without any luck, factory reset, recheck the credentials and still no luck. Tried using Android Nexus 5, iPhone 5s and nothing yet. Please any help will be appreciated.

Thanks.

@Ric1 is that a new core?

Did you managed to connect before?

Thanks. Not the first time it gets stuck in green light.

Yes, it is a new core.

By the way I have another core that connect without any problem.

Thanks.

What is the network settings of the WIfi that you are trying to get on?

AT&T uverse 2wire. WPA-PSK(TKIP) and WPA2-PSK(AES), current channel 6. 802.11 b/g.

Thanks.

Hmm looks ok. Do you have a mobile hotspot that you can use to test?

Yes, I already tested it using a Nexus 5 as mobile hotspot without luck.

Please, any additional step?

Thanks.

Can you search the forum for spark-cli tutorial and install it first? :slight_smile:

Thanks for you fast response. I’ll try as soon as I get home, tried with df_util and nothing happens.

You can also use DFU but im on mobile right now so more details later

Thanks a lot.

This is a procedure that I’ve used many times to fix a stuck green core.

Green Flash Fix:
-Connect your core via usb
-Hold down both buttons and release the reset button, keep holding until your core flashes yellow
-Open Node.js command prompt as administrator
-Start session
spark cloud login
-Update your factory reset version:
spark flash --factory tinker
-Run the patch
spark flash --usb cc3000
-Once your core stops flashing purple, and starts flashing yellow again, reload tinker
spark flash --usb tinker
-Plug your wifi credentials back in with
spark setup wifi

Thanks. I’ll try that as soon as I get home. In what sense is this flashing doing different than the DFU-Util?

Not entirely sure, but in the past I’ve tried everything and nothing else worked I found this is a sure fire fix.

I’m getting this error if try to run from the Node.js prompt:

npm install -g spark-cli
npm should be run outside of t
(Press Control-D to exit.)

and this is the result with the dfu-util:

D:\Spark>dfu-util -d 1d50:607f -a 0 -s 0x08005000:leave -D cc3000-patch-programm
er.bin
dfu-util 0.8

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2014 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to dfu-util@lists.gnumonks.org

Invalid DFU suffix signature
A valid DFU suffix will be required in a future dfu-util release!!!
Opening DFU capable USB device...
ID 1d50:607f
Run-time device DFU version 011a
Claiming USB DFU Interface...
Setting Alternate Setting #0 ...
Determining device status: state = dfuERROR, status = 10
dfuERROR, clearing status
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 1024
DfuSe interface name: "Internal Flash  "
Downloading to address = 0x08005000, size = 25248
Download        [=========================] 100%        25248 bytes
Download done.
File downloaded successfully
Transitioning to dfuMANIFEST state

Ok looks like CC3000 patch flashed properly. Did i blinked magenta and eventually reverted to blinking yellow?

Ric1 reached the daily limit. According to Ric1, it blinked magenta and now it is yellow. What is the next step?