[SOLVED]Two cores flashing green - Defective Spark Cores?

I recently bought two Spark Cores, but I’ve been unable to get them to connect to a WiFi network. I’ve connected to the same networks before, with different Spark Cores with no fuss.

I’ve tried connecting with the app, usb wifi configuration, factory resets, manual upload of known good firmware. Everything results in a flashing green light.

The app doesn’t appear to be able to communicate with the core at all, just sitting on the WiFi settings screen and spinning.

Can anyone provide additional steps/guidance on this?

Try the cc3000 patch/deep update if you haven’t already. It might just fix it. There are instructions on this to be found in the docs (troubleshooting section if I’m not mistaken).

Hi @benwis,

Checkout the great support guide for flashing green here:


It’s very unlikely you received two malfunctioning cores, and is probably some combination of Wifi security type and channel, power, etc. :slight_smile:


Hi @Dave
Unfortunately I think they’re both defective. I’ve tried connecting to 5 seperate networks, 3 of which I used for testing an app on 2 previous spark cores.

I’ve since factory reset and updated them with the latest firmware. I could detect no change after that, still flashing green. Thanks for the guide though.

Are you talking about the CC3000 patch/deep update, or just the most recent Tinker version?

1 Like

I had the same issue, the CC3000 patch @Moors7 suggests worked for me.


This turned out to be some combination of the CC3000 patch and maybe a factory reset. I don’t know why, I had tried that before. Oh well, I’ve since sent off the cores. Thanks for the help!

1 Like