Another flashing green light issue [Solved]

I have just received my two new spark cores, one with a chip antenna, the other with uFL. The uFL one connects fine first time to my home and work WIFI, but the chip one will not go past the green flashing light connecting to WIFI network stage, even with the core held right next to the router. I have tried all the suggestions I can find, including connecting over usb, but no success. On my work WIFI at least I do not have access to the router to change channel etc, but as the uFL works I would presume they are fine. Could I have a faulty chip antenna? does anyone have any other suggestions?



If you have spark-cli installed, try doing a patch with spark flash --usb cc3000 via DFU mode.

Be sure to update your spark-cli if you have not done it in a while. :wink:


Thanks for that kennethlimcp. I don’t really understand what you have suggested or why, but I am in the middle of following your instructions from other posts how to do it. I will report back once I have given it a try.

I have tried to get as far with this as I can, but I can’t get node.js to respond to my comands. Once I enter for example ‘spark cloud login’, node just sits there with three dots and does not respond; see below. what am I doing wrong?

Can you try using the Node.js command prompt?

You should be able to see it in Programs

Unfortunately I get exactly the same thing

Dont do it from node it gives the 3 dots as seen in the attached pic,

just do it in the cmd prompt…


Thank you ever so much kennethlimcp and Hootie81. I had tried calling spark directly from cmd, but it had not recognised the comand spark before. After your last post, it dawned on me I wasn’t doing things as an Admin. Once I realised my mistake it all started to work, and I have now patched my core and it conects straight away. Thank you again for your help.