Spark core cannot connect wifi Flashing Green-RESOLVED

My core has been working perfectly for months on a breadboard.

I soldered it onto a new PCB board yesterday (same circuit and parts as the bread board) and it worked fine for about 6 hours.

Now it flashes green and can’t connect a problem it never had before. I put an oscilloscope on Vcc, highest voltage was 3.48 volts during PicMX32 programming, otherwise rock steady. The chip I’m using programs at 3.2v, not 13volts!

Tried to reclaim using the spark phone app, reset it to listening mode, blinking blue, it switched to rapid green and there it remains. I did a factory reset, same outcome. I did an attempted USB claim by spark cli. It was able to connect to the PC in listening mode, installed the correct drivers, got the command line software working. Unable to get to the breathing cyan state, it remains flashing green.

I did the usual router reset, no effect. My spark is flashing green 2 feet from it, certainly range is not the issue.
Unable to get it connected using USB or a bench top power supply with lots of extra amperage…

Nothing else is changed. My next step would be to attempt to desolder it off the board and try it free of my circuit. Hard to desolder it off given the number of pins. Wish I had my photon to try another part…

I’m open to suggestions.

Regards to all,

Stuart

Have you tried running the TI CC3000 patcher on it again? CLI is the easiest way.

spark flash --usb deep_update_2014_06

Then re-setup the SSID etc and reflash your code.

Hey Dave,
Perhaps a silly question, why would this matter?

OK Dave, I went through a few steps:

  1. A sliced the power trace on my PCB to the Spark’s 3.3v input. I was then able to power the spark directly from USB without anything in my circuit being powered. This eliminated my PCB from the equation, any power spikes , noise etc, leaving the spark as the only powered element.

I was still not able to connect a previously healthy core either by phone app or USB. I’m not sure if I’m relieved or not.

  1. I attempted to do the deep update. I was able to get the core connected by USB and in DFU mode. Updated the drivers. I got stuck with being unable to install DFU utils and figure out how to point a windows command line at it. I didn’t cut my teeth on Linux or DOS so it remains a bit of a mystery to me. Do you realistically think that the deep update would make a difference anyways?

Thanks, Stuart

I went through a few more steps:
I watched this video to help the installation: https://www.youtube.com/watch?v=xBCxYbtDbVA
I was able to get through the steps on https://github.com/spark/firmware until

dfu-util -d 1d50:607f -a 0 -s 0x08005000:leave -D core-firmware.bin

which wasn’t able to download in the command line.

On doing the deep update via spark cli I got:

Error during download get-status
flashed!

Similarly spark flash --usb cc3000 also failed

At this point I’m not sure what to do. Help is appreciated as my core still flashes green…

I have had the flashing green from brownouts on the power supply , and just a handful of others have had the same with lipo’s going flat.

The trick is flashing the CC3000 patch a few times till it works

Can you see at which point the cli flash fails? Or does it tell you the error?

1 Like

Hi Hootie,
Here are the steps I’ve taken:

npm install -g spark-cli
followed by
spark cloud login

Successful login
Placed in DFU mode then

spark flash --factory tinker - timed out error

npm install -g particle-cli

spark flash --factory tinker

spark flash --usb cc3000

I had to do this twice. Then it flashed pink and I was able to restore my build software. The only difference that I did this time was that I installed Python 2.79.

Currently unable to send an email with IFTTT. Have you noticed any behavior on your end transitioning to Particle?

Thanks, Stuart

Disregard, IFTTT is up!