Flashing Green after months of being fine

So my spark has been deployed for a few months now, monitoring the coffee in our office. :smiley:

Out of the blue the Spark just started flashing green the past day or two. The wifi is still working, the password hasn’t changed. But the spark can’t connect. I took the spark off the breadboard and tried all the suggestions in this thread, and still no luck. To be more specific I tried:

  1. Factory reset, re-enter wifi credentials
  2. Factory reset, DFU mode -> cc3000 firmware update -> spark_tinker.bin upload -> re-enter wifi credentials

Still no luck. Flashing green. Can someone help me troubleshoot this?



Which CC3000 patch did you use? Try this: https://github.com/spark/spark-cli/blob/master/js/binaries/cc3000-patch-programmer.bin?raw=true

@kennethlimcp I used the one in the cc3000 repository here. I will try the one you linked, as it appears to be different.

Updated that firmware, then followed up with Tinker. No dice…still flashing green after entering wifi creds.

@osman, are you using CLI? If so, you can get the latest CC3000 patch by doing:

spark flash --usb cc3000

You may also want to update the bootloader though it is only required for the new wake-on-pin modes of Spark.sleep().

Yeah, that didn’t help either. Using spark-cli 0.4.94

@osman, has anything changed outside the Core like your wifi router/AP or channel or a new router/AP? Have you tried bringing the Core closer to your AP?

I had that problem with an original core so I reflashed the cc3000 then tinker and reset the wifi credentials via the Android app.

AFAIK nothing has changed, but here at the office the IT department could have changed something. I will say that it is very unlikely the router changed, and I know the wifi creds didn’t change. Maybe I’ll take it home and try to connect it there.


Nope, no luck at home either. Tried both WPA and WPA2. I think the wifi is fried or something.

Trying to connect to my phone’s hotspot is failing as well. I am going to e-mail support. Thanks for all your help folks. :beer:

I’m having a similar issue. Just got mine so I’m not entirely sure how it’s supposed to work, but I haven’t been able to set up via smart connect at all, and I can get it to connect to wifi via usb, but trying to put on the cc3000 firmware sets it in a constant flashing green mode that I need to reset to fix.

If you find out the source, please post.

I ended up emailing support and got a replacement.

1 Like