Wifi connection issues [Resolved]

I searched a lot of posts and performed a lot of troubleshooting and I am completely lost.

The issue:
The core has been working fine for weeks. One day, after flashing the firmware, it wouldn’t connect (it was stuck at flashing green). Every time I reboot the core, re-flash it, or clear its memory I get the same result, stuck on green flashing.

Things I’ve tried:

  1. I’ve checked the basics (SSID and password are correct). .
  2. The router is 802.11b/g, has a channel less than 10, there is no captive portal, and it is not a complex network. It uses WPA2 key. None of my router settings have changed before or after it stopped working. It is a comcast router. The spark core sits no more than a foot away. It is not being blocked by anything special on the router (like mac filtering).
  3. It is plugged into a usb from my PC. It should be providing enough power (especially considering it worked fine for weeks).
  4. I’ve patched the with the new CC3300 firmware. I’ve updated, rebuilt, and flashed with the most recent firmware. I’ve also flashed the latest tinker version.
  5. It has an antenna that is connected properly.
  6. I’ve tried connecting it to a mobile hotspot, same issue.

All my flashing has been through USB DFU-Util. I have used the same process multiple times over the course of weeks before it stopped connecting.

Every time I reset the core, it goes through the normal procedures, it just never connects to the wifi.

Any suggestions would be much appreciated, thanks!

Heyya, in short, when such things happen, your best bet is to perform a CC3000 patch and it should work fine.

Be sure to use the latest Spark-cli version though. There’s some issues with maybe the cc3000 EEprom and something got corrupted along the way IMO

Thanks for the quick reply!

I installed Spark-cli and followed the readme here: https://github.com/spark/spark-cli

Whenever I flash with the CC3000 patch it blinks magenta for a few seconds then starts blinking yellow. From there I have tried:

  1. Flashing tinker (spark flash --usb tinker)
  2. Deep update (spark flash --usb deep_update_2014_06)
  3. firmware update (through dfu-util)

After doing any of these steps, it blinks blue. Then I try running “spark setup wifi” and get the message “I didn’t find any cores available via serial”. I tried updating my drivers for the spark core, but windows says my drivers are already up to date.


If I use the spark app, I can get past the blue blinking back to green…
wait… it just connected.

Thanks for the help! I tried doing all the steps mentioned above (except for the deep update) through dfu-util (didn’t have spark cli installed). Is there a difference between these two methods? Or might the deep update have helped?

You can try unplugging the core and then plugging back in. Windows has some unexpected behaviour with serial ports.

As a sanity test, browse Device Manager, and look under “Ports” - you should see “Spark Core […]” listed.