Wifi never/not working; tried 3 APs + Putty config + all recommended troubleshooting = fails to connect to wifi

I’ve ran through all the troubleshooting steps; cleared memory,factory reset. I used Putty to add Wifi credentials when the App failed. I have tried 3 different access points: 1) Ubiquti Unifi, 2) D-Link , 3) Cisco Aeronet; all b/g/n friendly, all WPA2+PSK. Powered over USB and a 5v, 750mA charger. Just flashes green. Chip antenna.

Received Spark device early March. Faulty device?

Please advise.


So it went from Blinking blue --> Solid Blue --> Blinking Green and remained?

Any idea what’s the:

  1. channel number and can you try WPA?

  2. Also get to b/g mode only if possible.

  3. Does the core ask you for wifi security type?

EDIT: I’ll guide you through the best i can as i just did with another owner 3 days back…

Best if you can use the Tinker App to send through wifi. At least we can tell if the core managed to receive the wifi credentials via the router

Let’s hope it’s not some issue on the recent cores :slight_smile:

@Dave do you happen to have a recent core lying around or a core fresh out of the oven to see if this is happening :dancer:

1 Like

I don’t think there is a recent manufacturing issue, but a small percentage of cores (less than 1%) sometimes don’t ‘take’ the cc3000 patch the first time at the factory, or issues develop after shipping, etc. Please keep us posted!

I’m not sure if you are located in the US, but also make sure you’re not using the 2.4Ghz channels outside the US regions (1-11).


I have the same problem

Blinking blue --> Solid Blue --> Blinking Green (yelllow?) and remained?

i tried with different WiFi configuration but there is no way to claim it!

any idea?



@mpous, that’s interesting!

You have time for a chat to get things working out?

1 Like

sure! my skype marc.thethingsio

All set and ready :wink:


Looks like @mpous is experiencing a bad credentials


Gonna get him to swap his keys and drop you a mail :wink:

Spark-cli would probably be better but the setup is gonna take a while…

Thanks for the heads up! :slight_smile:

Do you think we will ever achieve a one step keys doctor somehow? :slight_smile:

Auto install stuff, configure etc

Yes, I think the big hurdle right now is providing binaries for node-serialport and the other compiled modules so that people don’t need to compile them when installing on Windows. That means we need to come up with a fix and send it as a pull request to those respective modules. When we have that, the installer will be much more smooth. We’re also talking about a simple Windows Installer wizard that also takes care of the respective bits (installing node, etc). Good installers always seem to take more time than writing the first version of a tool, so I wanted to get the tool out first. :slight_smile:


I’m having the same problem:

Blinking Blue / Solid Blue / Blinking Green.

I’ve tried different access points, setting the spark core up through the iphone app and using screen (mac os) with the same result.

I tried loading the CC3000 firmware with the same result.

I noticed 2 people posted to this topic with this problem but didn’t see any sort of resolution or fix. Could someone post whether they were able to fix this issue and how?


Hi @blue182,

I think generally the ‘blinking green’ issue is resolved using a combination of applying the cc3000 patch (remember to hold down the mode button, and wait until the core stops blinking magenta), and loading the newer core-firmware (especially if you’re using WEP security mode on your access point) . There’s a guide for this here: http://docs.spark.io/#/troubleshooting/troubleshoot-by-color-flashing-green .


1 Like

Thanks Dave. I loaded the newest firmware and all is well. Appreciate your help!

1 Like

I finally got it connected! I put the newest CC3000 firmware and used WPA (as opposed to WPA2) and it’s breathing. Thanks for all the suggestions! Sorry it took so long to reply (2 kids),