[partly solved] WiFi Problems or non responsiv 3 out of 5 cores

Three of the cores 2 with updated firmware one with original

The two that work worked before the firmware update.
The top was that stopped working after a web IDE flash this one still will not connect even after a firmware update factory reset and WiFi reset.
I also have a core that still flashes white after a firmware update.

So in total 2 working cores and those happens to be the ones i ordered with out the build in antenna.

Any input would be great.

Hey @rasmussen,

I want to make sure I understand you correctly, so forgive me for being so verbose:

You purchased 5 Cores. Of the 5, you were able to setup and configure 2 of them without issue. Of the remaining 3 that cannot currently connect, one of them was configured correctly at one point, because you were able to update it through the web IDE. But, it didn’t successfully update, and now, even after a factory reset, it cannot connect to Wi-Fi?

Can you give me some more information about the other Cores? Did the SmartConfig process work, or are you configuring them all using PuTTY? What does the status LED display–it’s the most useful tool for helping us debug connectivity issues? Could you provide a video that might give me some more information about the status of the LED?

Also, if you haven’t already, you should refer to our troubleshooting guide, which is current with all of the best fixes for known connectivity problems. I hope that helps. If you provide some additional information, I’m happy to troubleshoot further. You can also email us at hello@spark.io for additional support.

Thanks for the quick response.

Link to a quick video



Thanks for the video. That is extremely helpful to us. Let’s start with the two Cores that are flashing green. As the troubleshooting guide mentions, the most common reason for their being unable to connect to Wi-Fi is that they are underpowered. I’m not sure how they are being powered, but the CC3000 requires up to 300mA of current during startup, so we recommend using a wall wart adapter that’s commonly used for smartphone chargers (rated for 500mA to 1A). If you’re using an unpowered USB hub (or even a powered one, especially with 3 Cores connected), it may be that they’re not receiving enough power to connect. Try powering and configuring just one at a time.

If your Cores are still not connecting, try the other common fixes–clearing the CC3000 SSID/password memory or a factory reset. And, of course, double check your network password :smile: Those are all documented at the link in my last post.

For the Core that only flashes white, this seems like a less common problem that could be caused by a variety of issues. Does it continue to flash white if you perform a factory reset? Is the Core heating up more than your other Cores?

Another one of our customers who had this issue was able to resolve it by testing on another network. Could you verify that you have the same issue after a factory reset and testing on a new network? That will help us narrow down the list of potential causes.

I will try using another access point tomorrow the cores where powered by two Apple five watt USB adapter, except one of them which connected to the PC via USB. So I don’t think powers a problem because it works with the all the psu I have been testing.

The one that seems bricked flashes white from the start it doesn’t go green or another colour what I can get it to flash yellow in dfu mode.
If I do a factory reset on it it alternates flashing white and a steady white.
I cannot get it to flash blue doing a Wi-Fi reset.

Hey Heres a quick video. any ideas?



Fixed the Wifi Problem with the cc3000 patch




Sorry for the slow response. As Zach mentioned [in his post] (https://community.spark.io/t/team-traveling-apologies-for-slow-responses/1346), most of the Spark team has been traveling this week. I’m glad that you were able to resolve the issue, however. Thanks also for such awesome video documentation–this will certainly help if there are others who are having the same problems as you.