Flashing white, no connection [SOLVED]

I know there are similar topics already. I have read them all.

I have a core which was working at home, brought it to work and does not work.
I’ve deleted its memory by holding MODE 10s
Setup the company’s wifi with the android app. It will keep blinking green.
I’ve tried to make a hotspot with my mac and connect to that network instead, will blink green a split second then blink white.
I’ve tried factory reset and repeat the above, same results.

Then I am trying making my phone a hotspot and pass the SSID/password via USB to the core. It goes blinking white and the spark web IDE can not find it.

I’ve resetted it sevreal times, deleted memory every time, etc, nothing worked so far but it worked at home.
The network my mac provides is 2.4GHz channel 4 which should be ok for the core.

I’ve even downloaded and resetted the firmware with the dfu-util.
The bootloader also can not be wrong as it works at home.

Any idea?

OK, I have solved it.
My company has a firewall which somehow was avoiding the core to work, that’s my theory. I just can not make it work with the company’s network.

I could make it work with my phone thought. I was just not activating 3G for some reason, now it works correctly.

So it seems that flashing white means ‘I could connect to the network but I could not get Internet access’