Flashing White LED, Can't Connect

I just received my Spark Core, tried to set it up, and ran into the continuous blinking green LED. I tried to do a factory reset and I also tried clearing the memory, but neither worked. Now all I get is a blinking white LED. If I try to hold the Mode button for 10 seconds (to clear the memory), the LED goes from blinking white to solid white.

I have tried reloading the firmware using dfu-util. The output of which suggests it was successful, but I’m still getting the blinking white LED. I also tried loading the cc3000-patch-programmer. It appeared to load successfully. The LED turned off, but I did not a magenta LED when I pressed the Mode button. I basically get no response unless I either put it back in dfu mode or reset to factory settings, upon which the blinking white LED returns.

Any thoughts?

Got your email and responded there @pdigm9—looking forward to getting you all set up!

I am having the same problem with one of my cores please post any answers :slight_smile:

Hello @rasmussen
Most of the time such a problem can be fixed by factory reset, followed by Reflash Tinker via the iPhone App. You can also provide WiFi credentials over the USB if the iPhone app fails to work.
Factory reset: http://spark.github.io/docs/#/start/buttons
Credentials over USB: http://spark.github.io/docs/#/connect/connecting-your-core-connect-over-usb

Thanks for your response

I have tried that. i have a total of 5 cores. 3 with ant and 2 without. its the 3 with ant i cant get to work. only one of 3 the have worked and stopped after the core connected fine when i got it and i played around with the thinker app. Then i flashed it from the web ide and the app ran on the core. after that i wanted to reset it and did a factory rest on the core, after that reset i can not get it on my WiFi i have two other cores that i have not done a factory reset on and they work fine.

2 cores work fine with out ant. at close range to wifi router.
1 worked when i got it after reset no connect. only green flashing
1 never connected only green flashing
1 flashing white.

Hi @rasmussen,

If a core is stuck “flashing white” forever, it can indicate that the core isn’t “booting up” normally. This could be the result of a bad copy of the firmware, or an issue with the hardware of the core itself. Does the core LED change colors during the factory reset process (start blinking yellow, fast white, etc)?

If the light does change colors, it could be bad software, it’s possible to flash new firmware onto the core using dfu-util https://github.com/spark/core-firmware#3-device-firmware-upgrade-utilities and you can grab the firmware here: https://github.com/spark/core-firmware/blob/master/build/core-firmware.bin .

If this doesn’t help, please email us at hello@spark.io!


Looks like you were able to flash the firmware successfully. The Core flashing white is indicative that the STM32 is not able to initialize the CC3000 WiFi module and is stuck. If this Core has always flashed white ever since you received it, then I would recommend getting a replacement from us.

We have observed that few of the cores have cold solder on the CC3000 and reflowing the solder on these Cores usually fixes this issue.

What about return shipping and such ?


I seem to be having the same issue. My Core has made it as far as connecting to the network twice but 99% of the time when I unplug and reconnect it I’m greeted with a white flashing LED. I’ve done numerous factory resets and reflashed the firmware with dfu-util but nothing has changed :frowning:

@rasmussen If you can provide your details to hello@spark.io , we’ll be glad to figure out the replacement/return shipping.

@thip In your case, it seems like the hardware is working fine. Could you try using a different power supply? Sometimes when there isn’t enough current provided, the Core fails to initialize the CC3000 module.

I’ve tried the supplied USB cable, my mains phone charger and a 5v bench supply going into the Vin and Gnd pins but I’m still having the same problem.

Hello @thip
So the power supply seems fine then. May I suggest a few more things to consider:

  1. Try loading the latest patch for the CC3000 : Instruction here
  2. Does the Core keep flashing white perpetually? Does it ever turn to flashing green?
  3. Have you tried this out with an empty user application?

I’ve tried installing the patch, it seemed to go smoothly but the LED never turned magenta as the quick deploy instructions describe, it just switched off.

The core does flash white perpetually, the only time I can get to to go any other colour is when I enter the firmware loading mode.

I can’t load applications onto it so I haven’t managed to get an empty one onto it (or is there a way to do this through the firmware loading mode?)

I think we may have narrowed down on your problem here. Looks like the patch for CC3000 may not have completed successfully, thus rendering the CC3000 useless.

During the patch process, did the LED turn to flashing magenta after pressing the MODE button. It should flash magenta for about 10seconds followed by a solid magenta - indicating a successful patch. Can you try this process again?

No magenta at all, it just stays dark. Looking at the output from dfu-util there are actually a couple of errors and warnings, I got the impression that “Error during download get_status” is insignificant but what about the others?

    thip$ dfu-util -d 1d50:607f -a 0 -s 0x08005000:leave -D cc3000-patch-programmer.bin
dfu-util 0.7

Copyright 2005-2008 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2012 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to dfu-util@lists.gnumonks.org

Filter on vendor = 0x1d50 product = 0x607f
Opening DFU capable USB device... ID 1d50:607f
Run-time device DFU version 011a
Found DFU: [1d50:607f] devnum=0, cfg=1, intf=0, alt=0, name="@Internal Flash  /0x08000000/20*001Ka,108*001Kg"
Claiming USB DFU Interface...
Setting Alternate Setting #0 ...
Determining device status: state = dfuERROR, status = 10
dfuERROR, clearing status
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 1024
No valid DFU suffix signature
Warning: File has no DFU suffix
DfuSe interface name: "Internal Flash  "
Downloading to address = 0x08005000, size = 23216
File downloaded successfully
Transitioning to dfuMANIFEST state
Error during download get_status

I tried this at my end and I do get the same log but its insignificant and can be ignored. Please remember, upon the completion of the patch transfer, the LED will turn off - indicating firmware download complete. You then need to press the MODE button for atleast one second (or until the LED starts flashing magenta) to initiate the patch transfer on to the CC3000.

Does the LED remain OFF even after pressing the MODE button for a second or two?

Yes, but I’ve noticed that the small blue LED remains on. Is this by design or is it getting stuck in the reset?

The blue LED being dimly lit is indicative of the STM32 microcontroller to be in the ‘ready to be programmed mode’.

If the above step has failed, you can drop us an email: hello@spark.io for a replacement. In the email, add a link to this forum thread.

Ok, thanks for all your help :smile: