Blinking white LED after reboot

Hallo. I have a problem with spark because the white led puls.
I have done reboot of spark two times. First time with spark-cli and second time with press on the buttons.
But the white puls apperas only. What i have to do???
For information:
Before of the firmware update with spark-cli, the spark has been worked.
The version of spark is 0.4.94

Have you tried a factory reset already, that might help?

Hi, yes I’ve tried. I’ve just tried the instructions:

dfu-util -d 1d50:607f -a 1 -s 0x00020000 -D factory_firmware.bin
dfu-util -d 1d50:607f -a 0 -s 0x08005000:leave -D factory_firmware.bin

from main page with the factory_firmware.bin.
But it doesn’t work! the LED is white and there is also a little green and little blue.
What can i do?
Thanks for help.

Hi, here is one more information. The Spark is in DFU-Mode and answer on the command dfu-util -l is:

dfu-util 0.8

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2014 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to

Found DFU: [1d50:607f] ver=0200, devnum=2, cfg=1, intf=0, alt=1, name="@SPI Flas
h : SST25x/0x00000000/512*04Kg", serial="8D88189A5153"
Found DFU: [1d50:607f] ver=0200, devnum=2, cfg=1, intf=0, alt=0, name="@Internal
 Flash  /0x08000000/20*001Ka,108*001Kg", serial="8D88189A5153".

Is there any solution for this problem?

Could you try to do a manual factory reset? Simply follow this instructions: Let me know how that worked out for you.


I’ve already this done. At the end LED is blue, then comes the questions about WiFi.
But after that the LED is green and then again white.
It doesn’t work!!!

According to the docs, now is the time to call for backup. So I’d like to ask @harrisonhjones and @Dave to lend a hand. They’re the active Spark forum guys, and should be able to figure something out.


after a factory reset, you should see a blinking blue status (listening mode)

You will now be able to send in Wifi credentials and eventually have a breathing cyan status.

1.) Have the core ever entered breathing cyan?

2.) Just be sure to have an antenna connected if you bought the u.fl version

3.) Have the core been claimed already?

Hi, @kennethlimcp

after sending WiFi credentials, there isn’t a breathing cyan status. Only white.

  1. yes, the core has worked until samday, I could flashed the programs.
  2. the antenna is on the Spark
  3. yes, the core has been claimed already.


Since you are using dfu-util, can you flash to patch to your core:

Once it’s done (reverts to blinking yellow after blinking magenta), perform a factory reset and try again :wink:


Is it correct with this command to flash:

dfu-util -d 1d50:607f -a 0 -s 0x08005000:leave -D cc300-patch-programmer.bin?


1 Like

bingo :wink:

Sorry kennethlimcp,

it still doesn’t work :((.

After a factory reset, led is still white pulse.
Have you another solution?

usually a white pulse means there’s some issue communicating with the CC3000.

I wonder if it got damaged somehow while you where doing a project? Maybe you should try to explain what you have done and what you did that made it enter this state.

Hi @nininana,

Unless you hooked up your core to high voltages, or poured water on it, it’s unlikely you broke it, and it sounds like it was working and you’ve been flashing programs to it, so it’s unlikely it came broken. Can you perform these three commands with the CLI, and post the full output? Also make sure you’re on the latest version of the CLI, so it’s the right patcher, tinker, etc. :slight_smile:


1 Like