Help Wanted - Pulsing white and not communicating

Hey Folks

I could use some help please.

I’ve had my Spark for a few weeks and it was working fine up to last night. Now it is pulsing/flashing white/cyan but not going online, listening, or communicating with me via serial or cloud.

I haven’t been able to get it back into listening mode, so I think that prevents me from connecting via serial.

I did manage to use dfu-util to connect and flash it (below). After flashing (deep update 2014 06), it looks like it is breathing cyan, but still is not connecting. It seems like DFU mode is the only way I can communicate with it.

Apologies but cyan and white look pretty similar to me so I may be mixing up the colors…

After factory reset - flashing white
After restart - flashing white
After deep update - breathing cyan
After restart - breathing cyan
After I press Mode - solid cyan
After restart - breathing cyan

C:\Users\Peter\Downloads\dfu\dfu-util-0.8-binaries\win32-mingw32>dfu-util -d 1d5
0:607f -a 0 -s 0x8005000:leave -D deep_update_2014_06.bin
dfu-util 0.8

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2014 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to

Invalid DFU suffix signature
A valid DFU suffix will be required in a future dfu-util release!!!
Opening DFU capable USB device…
ID 1d50:607f
Run-time device DFU version 011a
Claiming USB DFU Interface…
Setting Alternate Setting #0
Determining device status: state = dfuERROR, status = 10
dfuERROR, clearing status
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 1024
DfuSe interface name: "Internal Flash "
Downloading to address = 0x08005000, size = 93636
Download [=========================] 100% 93636 bytes
Download done.
File downloaded successfully
Transitioning to dfuMANIFEST state

Any ideas?



Maybe a video is better for us to diagnose this.

Good idea! Here you go:

Hi @Peter

Did this core ever work right? It looks like flashing white to me which could indicate a hardware problem.

When you say you are resetting it, you are pressing the wrong button–that is the mode button.

Yes it was working - I’ve had it for a few weeks and created my own firmware, etc.

It’s been pretty reliable but I’ve had to reset a couple of times before when it was unresponsive (I blamed the wifi).

I agree that it looks like it is flashing white.

Any ideas for what else I can try?

Can you try patching the CC3000?

Using spark-cli, place the core in DFU mode and run this:

spark flash --usb cc3000

The core will blink magenta and eventually revert back to blinking yellow again.

Once that’s done, run spark flash --usb tinker

Let us know how it goes :slight_smile:

Thanks that was a good tip - but unfortunately it didn’t resolve it.

The flash command executed ok, and the spark started blinking magenta, but it never stopped blinking (over 1 hour later). I re-tried a couple of times but got the same result.

Other attempts:

I flashed factory_firmware.bin (worked) and then cc3000 (failed, as before)
I flashed deep_update_2014_06.bin (worked) and then cc3000 (failed, as before)

So it seems that my cc3000 is unhappy about life. Is there any other way to revive it?

What colour was it blinking after flashing magenta?

It should revert to Blinking Yellow and flashing tinker after the patch should bring you to Blinking Blue.

If it’s still flashing white, i’ll recommend to open a ticket at to get it change and save you time from all the troubleshooting! :smiley:

Both the breathing white, and the never-ending magenta on the cc3000 patch sounds just like the behavior I saw when my cc3000 nvmem got corrupted. I’m sorry to say I didn’t find a solution to that. Yours may or may not have the same problem, but the symptoms sound similar.

So… how do I go about getting my Spark fixed or replaced?I don’t see anywhere to submit a support ticket, and Spark doesn’t seem to have a phone number…

Hi there @Peter I did get your support ticket and we are working on a solution for you. Just wanted to let you know that we haven’t forgotten about you.

1 Like

Awesome - thanks very much!


since now I have the same problem. The Core was working fine by now. If I connect it to the power supply it only pulsing white. Flashing the cc3000 patch ends in a endless magenta blinking.

Is my Core defect?

Thank you for your help!

Kind regards,

It would seem that way. To be sure, flash tinker

particle flash --usb tinker