Constant white flashing LED, never any other color

Hi, So I just unpacked my new Spark Core and tried plugging it in to connect to the android app and get developing… but I hit a snag. From the moment I first plugged it in (MacBook USB port) It has been quickly breathing white on the main LED (approx 2x per second).

I have never seen it turn blue or any other color (except for yellow when i entered DFU mode.) I tried looking around this post Fast flashing white then solid blue then repeats, but seems like it can’t help. Note: I did that on all on a Windows computer since it seemed easier than on a Mac. I had problems with Zadig, but either way I’m stumped at what to do.

Any suggestions?

I’m wondering if that’s really the blinking “Blue” that you’re seeing. It’s very bright. This would indicate (http://docs.spark.io/#/start/leds):

Flashing blue: Listening mode, waiting for network information.

I don’t have the Android or IOs app, so I had to set it up over Serial connection (using Windows). This doesn’t require the dfu-util or Zadig. It does, however, require a Windows driver file. Follow the instructions from http://docs.spark.io/#/connect/connecting-your-core-connect-over-usb

If you are really flashing white, I would follow the instructions for a factory reset (http://docs.spark.io/#/connect/troubleshooting-by-color-main-led-off-small-blue-led-dim) and then see what happens from there.

Dave O

Hi @dglover,

Just checking, did you try a factory reset on your core? – Power the core, hold down both buttons and then release the reset button. Keep holding while the core flashes yellow, and then release when it starts flashing white. – Does that help at all or is it still only ever flashing white?

Another thing to try would be to grab a copy of the firmware binary, and try flashing that onto your core while it’s in dfu mode. Instructions for that are here: https://github.com/spark/core-firmware and the binary is here: https://github.com/spark/core-firmware/blob/spark_2/build/core-firmware.bin

I am pretty sure it is white, because all of the diodes inside the RBG LED are on, and the light is pretty dang white, no tint of blue. When I try to use the Android app, all I get is “No Cores found. Try Again”. They are a few inches from each other.

I have tried using the Serial connection using windows, but it doesn’t appear listed as a port, so I can’t connect (via OSX), I will re-try on windows later. But this is odd because multiple arduinos have always been listed on this computer,

@Dave I have tried several factory resets. It goes back to the same flashing white. That vid is from just after a factory reset.

I am going to try to flash the core, but to be honest, the last time I was trying that (see first post), I was having problems with Zadig/dfu-util.

Update : parkCore doesn’t appear on the list in Zadig on Windows, and doesn’t appear as a serial connection on Mac/Windows. I’m out of my comfort level doing anything else with it.

Hi @dglover,

If flashing new firmware doesn’t help, it sounds like there could be an issue with your core and we should do a replacement. Can you email us at hello@spark.io if it doesn’t work?

Thanks,
David

I will email you guys there, with reference to this post.

Thanks @Dave.