Spark core not responding. Only small blue LED is on


#1

I can’t get my core to work. I was experimenting with the Wire library, and after flashing it the core, the core acted normally. After discovering that the code didn’t work, I restarted the device. But the RGB LED didn’t come on, only the small blue LED in the corner. I can’t factory reset it, the device doesn’t respond.


#2

Hi @gman4455 - can you share the code that you flashed to the Core?

Also, is the blue LED in the corner on kinda dim?


#3

I was having similar issues. I did the manual version of the factory reset – #3 at https://community.spark.io/t/spark-core-troubleshooting-guide-spark-team/696. I now have flashing LEDs again!


#4

@gman4455, let us know if @wgbartley’s suggestion fixed it for you :smiley:


#5

I performed the manual firmware update and I’m eventually back to only the D7 LED on. Here’s what I did:

  1. Reset into DFU mode and followed the instructions for manually updating the firmware.
  2. Connected the Spark to wifi using the serial connection (pressed “w”, entered SSID and password)
  3. Spark rebooted, connected to wifi, connected to the cloud, and looked like the “breathing” cyan for about 1 second.
  4. Spark began flashing magenta with a pause at solid magenta for a couple of seconds and then went back to flashing magenta.
  5. Spark is now unresponsive with only the D7 LED on (should we call this “D7 mode”? :wink:

Is it possible that the firmware binary from the AWS URL in the other article is outdated? Should I try rebuilding the firmware from the core-firmware repo?


#6

@wgbartley, it sounds like your Core got stuck in the middle of an update after the factory reset. The flashing magenta indicates that the Core is updating it’s firmware–if it goes blank or solid magenta, it means that the process got interrupted and needs to be restarted. You can accomplish this by quickly tapping the RST button on the Core. It should re-connect to the internet and automatically restart the update. If it’s a manual firmware flash through the IDE, you will have to reflash it manually.

We’ve just completed and will soon be pushing an improvement to the robustness of over-the-air updates that should largely prevent this from happening.


#7

Tapping reset seemed to do the trick. I’m finally breathing cyan on this one. Thanks!!!


#8

I may have spoken too soon. As soon as I tried to flash from the web IDE, I’m back to non-responsive. I can do the whole manual firmware flash over and over again and I eventually wind up back at non-responsive. I’ll let this Spark sit on my desk until the firmware update is ready to go.

Thanks!


#9

@wgbartley @will I managed to fix it. Somehow my core wouldn’t factory reset the other day, but when I tried it today, the factory reset worked perfectly fine. Now my core is fully functional again. Thanks!


#10

I’ve experienced the exact same issue with my spark core - Out of the box.

Even when I try to factory reset (Hold ‘mode’ and tab ‘rst’ I’m unable to make my spark core go into listening mode. The RGB LED is always off.

I’ve tried both external supply (5V), battery supply (~3,6V) and USB supply (both from computer and iPhone charger). Always the same.

I’m unable to see a COM port on my PC aswell.

Is my spark core defect and does it have to be replaced?

Any help would be appreciated!

-Thomas


#11

@tjelin If you are seeing the small blue LED on, but the main RGB LED is off, then it does sound like it’s defective (or rather it’s lacking any firmware, including the bootloader). If you have a JTAG programmer we can help you re-flash it, otherwise shoot me an email at zach at spark dot io and we’ll get you a replacement.


#12

Hi,

Just received an email from Stephanie @ Spark

That told me I might be able to re-flash it.
I have a SiLabs USB debug adaptor available at work. Do you think it could be used?
http://www.silabs.com/products/mcu/pages/usbdebug.aspx

Best regards,
Thomas


#13

Possibly so, although it will require quite a bit of tweaking, and we’ve never worked with that programmer before, so it might be better just to send you a replacement.


#14

Hello. Ok, should I send you an e-mail with the relevant information for shipping?

What about the non-functional core? Where can I send it?


#15

Yes, send your shipping information to hello at spark dot io, we’ll send you a self-addressed envelope to return the non-functional Core. Thanks!


#16

I sent an e-mail to hello@ 5 days ago regarding the same issue and haven’t received a response other than the auto-responder. I’m not sure if a forum post is the right place for it, but the forums seem to be more active/faster than an e-mail inbox.


#17

Just wanted to make sure you heard back on this; did you get a response from hello@?


#18

Nothing since the auto-responder on 1/2. I’ve been keeping a close eye on my spam folder, too. With everyone out of the office this past week, I wasn’t going to harp on it yet!


#19

Oops, looks like we marked your email as ‘resolved’ for some reason! Just sent you an email to follow up, sorry about the delay.


#20

Ok! I guess my Core is dead as I can only see a small Blue LED while the Core RGB LED is off. I’ve mailed support.