Core won't connect, and the usual restore/reset methods aren't working

Before today, my core was working just fine. Had some downtime at the office, so I played around writing a few simple cloud-controlled functions, everything was fine. It had previously worked well at my home network as well.

Now, though, I cannot get the Core to connect. I’ve gone as far as factory-resetting it; manually programming the wireless credentials just left it blinking green endlessly.

After using the Android app, it accepts my credentials, and begins flashing fuchsia as it does when it is being reprogrammed, then begins attempting to reconnect. It briefly flashes green, then rapidly flashes cyan for a moment, before sitting on a solid fuchsia light for a few seconds before repeating the loop all over again. Eventually, it will either begin blinking cyan as if it’s lost the connection, or it will just sit on a solid fuchsia light, as it is currently doing. It has done this both at my office and here at home; it’s worked fine at both places before.

I’ve tried to reload the factory firmware via DFU mode, but that only results in dfu_util.exe giving me the message “Opening DFU capable USB device… Cannot open device”

How can I restore my Spare Core to working order?

Just in case my description of the light sequence is tough to follow, (long day at work plus a few hours of graduate studies…), I attempted to take a short video to show what I mean.

Hello,

I have pretty much the same problem here. However, today is the first time I plug my spark. So, I never got it to work actually.

My spark goes through the same cycle: white->green->cyan->magenta->reboot. See this video:


I should also note that when it reboots, at the moment the magenta light disappears there is a small flicker on the blue D7 led.

If I factory reset, the first boot it updates (if it does not get stuck on a fixed magenta…), then reboot to enter this loop :(.

Could it also be similar to what some other people are reporting today, like https://community.spark.io/t/solid-magenta-after-a-few-minutes-of-flashing-magenta/636/35 ?

(Damn, seems I chose a bad day to start with my sparks… My second one does not even go through the flashing green :frowning: )

1 Like

I’m having the same problem here. I can tell it is connected to WiFi and has been given an IP, but that’s about it. The Core never stops cycling through its various LED colors. This was its first time was out of the box. I tried a factory reset, no change.

1 Like

Looks like im getting a similar issue as well, up until tonight my core has been able to connect and I’ve been doing plenty of work on it without issue.
I’ve let my core sit and go through the noted color cycle, but I noticed that every so often I get 3 red flashes. From the support docs this indicates that there could be some sort of outage in the Spark Cloud, but there isn’t anything noted from what I’ve seen.

If you guys let your core sit and attempt to connect do you see three red flashes eventually as well?

1 Like

Yep, I sometimes get the three red lights as well.

Hi all - we published a firmware update today with a bug in it, but the issue has now been fixed; if you do a factory reset, it should revert back to normal behavior. Sorry about that!

2 Likes

Thanks for your prompt response, Zach!

But even after a factory reset just now, I’m still seeing this problem. Is there anything in particular I need to do beyond factory reset to force it to load the new firmware?

Edit: Went to bed, woke up, everything’s cool now. Thanks again Zach.

1 Like

I have tried to reflash the core and I get the following

Dave-Appletons-MacBook-Pro:build daveappleton$ dfu-util -l
dfu-util 0.5

© 2005-2008 by Weston Schmidt, Harald Welte and OpenMoko Inc.
© 2010-2011 Tormod Volden (DfuSe support)
This program is Free Software and has ABSOLUTELY NO WARRANTY

dfu-util does currently only support DFU version 1.0

Found DFU: [1d50:607f] devnum=0, cfg=1, intf=0, alt=0, name="@Internal Flash /0x08000000/20001Ka,108001Kg"
Found DFU: [1d50:607f] devnum=0, cfg=1, intf=0, alt=1, name="@SPI Flash : SST25x/0x00000000/512*04Kg"
Dave-Appletons-MacBook-Pro:build daveappleton$ dfu-util -d 1d50:607f -a 0 -s 0x08005000:leave -D cc3000-patch-programmer.bin
invalid dfuse address: 0x08005000:leave
Dave-Appletons-MacBook-Pro:build daveappleton$ dfu-util -d 1d50:607f -a 0 -s 0x08005000:leave -D cc3000-patch-programmer.bin
invalid dfuse address: 0x08005000:leave

@calistra seems like your dfu-util is a little old at 0.5 could you install a newer version?

The devices are showing up correctly but the memory space of them are not

My first core connected using the App but I could not claim it so I used USB to get the hex ID.

I then checked setting the Wifi via USB and was asked for Wifi Type.

For the second, the behaviour was different.

It would not connect. It obviously connected to the app because it moved out of waiting mode to flash a kind of orange alternating with flashing cyan.

I reflashed using 0.7 successfully - but still cannot connect :frowning:

I still get alternating between green flashing and cyan flashing even when setting wifi params via USB.

Oddly - the second does not ask for interface type but the first one did.

@calistra,

You mean the 2nd did not asked for Wifi security type over USB?

What are you flashing over dfu-util? You’re like doing multiple stuff at one go…

  1. Settle on connecting the core successfully to the cloud 1st.

  2. Over USB or using the tinker App. Also, make sure if the core is a u.fl type, there’s an antenna attached.

  3. There’s no need to downloading anything through dfu-util when trying to connect the core to visit.

We had a similar case where the core kept blinking green and cyan but did not become breathing cyan. There’s a solution for that.

Can you try again to connect the core to the cloud and let us know the results? :smiley:

OK - both cores have chip antennae

using the app #1 would connect to the cloud but not #2

I could not claim #1 so I used USB to get the hex ID (i) and since I was there I also set up the wifi manually (w) then claimed it via spark IDE

#2 would not connect to the cloud from the App. You could see that it was trying to but it failed.
So I tried USB to enter the credentials. It asked for SSID and Password (entered ok) and reverted to switching between the flashing orange and the flashing cyan.

At this point I noticed that #2 did not ask:
Security 0=unsecured, 1=WEP, 2=WPA, 3=WPA2:

Since I was having no luck, and found on the forums that it may sometimes be needed to re-flash the core, I went where angels fear to tread and downloaded dfu-util (brew = 0.5, macports = 0.7) and the zipped stuff from the site, installed gcc-arm as instructed and while I could re-flash, no improvement was forthcoming…

So I can tinker with #1 but was trying to get both up before I try doing something really stupid (sorry - that should read “impressive”).

#2 core of yours has V01 of the factory reset firmware which doesn’t ask for security type.

Are you able to send wifi credentials to #2 via USB? What is the status of the led agter you sent and the core restarts?

Sorry - was a bit diverted…

Just reset my network (was using ch13 - now ch6)

Same - core #1 can connect core #2 cannot.

Set credentials over USB
SSID: Istana_Bahru
Password: ### correct password entered ###
Thanks! Wait about 7 seconds while I save those credentials…

Awesome. Now we’ll connect!
… etc.

I get a fast flashing orange with occasional fast flashing cyan

=== after power cycle ====
cyan slow flash (about 2 second) x 1
green flash (about 3 second) x 1
fast flashing orange with occasional fast flashing cyan

Orange sounds like a bad handshake with the cloud which means there might be some issue with the key on the core.

Are you comfortable installing Spark-cli and attempt to update the key?

If you ever had breathing cyan, this shouldn’t be a problem but looking at the symptoms, it’s worth giving it a shot!

FLASHING ORANGE (RED/YELLOW)
What’s the Core doing? My Core is flashing yellow/red/orange lights after it connects to Wi-Fi.
What’s the problem? A decryption error occurred during the handshake with the Spark Cloud

Yeah - why not. Will try later.
Silly question - you wouldn’t happen to be in SG would you? (Just guessing from the name)

Well indeed i’m from here :wink:

Ok - visit HackerspaceSG quite a bit (I live in JB).

I am using a mac and have been trying to install spark-cli. Having trouble with installing serialport module even though I updated the CLI Tools

Hmm try using sudo to install spark-cli or see this: