Time out on security - photon connection issues

Hello,

I have a photon that’s behaving very strangely!
The problem is similar to this post (which also didn’t seem to have a solution):

I am trying to set the photon up with another wifi network using “particle setup wifi” – I entered the credentials correctly several times, but each time it gives me this weird error:

I said: w
Serial said: SSID:
I said: NETWORK_NAME_HERE

timed out on Security 0=unsecured, 1=WEP, 2=WPA, 3=WPA2:
timed out on

When the time out happens, the photon goes from blinking blue to completely shutting off (LED indicator is off :open_mouth:)!

I tried factory resetting it (holding setup, pressing reset, holding setup for 10s until white blinking and solid white) but it goes back to flashing green, so the wifi creds aren’t erased!

I’ve also tried flashing the factory tinker firmware but it still has the same wifi setup problem.

What’s strange is that if I turn on my hotspot (the original wifi that the photon was set up with), the photon breathes cyan… But it doesn’t do that with any other wi-fi network that I’ve entered.

Any ideas as to what the problem could be? Help would be very appreciated!

Edit: I’ve also tried setting up wifi through the particle app – I get this error:
“Error! Setup process couldn’t configure the wi-fi creds for you photon, please try running setup again after resetting your photon and putting it back in blinking blue listen mode if needed”

@LeoW has the Photon worked before?

Yes @kennethlimcp, I initially set up the photon to connect to my phone hotspot and it still breathes cyan when I have my phone hotspot.

However, for any other wifi, it will blink green for minutes when I try to setup wifi for that particular wifi (I run “particle setup” when photon is in listening mode, additionally I’ve tried using the app but I get the big error sign noted in the edit above).

  • When I try to reset wifi credentials it’ll still remember my phone hotspot.
  • When I try factory resetting the device it’ll still remember my phone hotspot.
  • When I try “particle setup wifi” and enter credentials, the LED turns off when entering security credentials (note initial post)

When you perform a factory reset, does the Photon enter listening mode?

No – the Photon continues to blink green when it is factory reset (which is why this issue is weird).

It sounds like you might need to update the system firmware for the DCT area might be corrupted.

Someone from the :spark: team might have to take over from here. @harrisonhjones

1 Like

@LeoW Leo. Shoot an email to hello@particle.io and we’ll get you sorted. Thanks @kennethlimcp for the ping

1 Like

Thanks @harrisonhjones! How long does a reply usually take? I sent my email 2 days ago.

Shoot me a PM with your email. We’ve been pretty busy lately so it’s possible we just haven’t gotten to you yet. I’ll pull up your ticket asap if I know what email you sent it from

Thanks @harrisonhjones! Really appreciate the help, the firmware upgrade worked!

Just curious – how did the device configuration become unwritable? I’ve been using several other photons in the same way and they don’t seem to have this configuration problem. How is this firmware upgrade different from going to the “modules” folder (firmware/modules) and using the command “make PLATFORM=photon clean all program-dfu” to upgrade firmware?

Have a great 4th of July weekend! :smile:

1 Like