[solved] Wifi setup failed even after factory reset

Hello,

i just received my photon 2 days ago. While the first setup was easily successful, after play the particle CLI, i wanted it to reset it, so I did a factory reset. However, what ever I tried (google app, iOS app or particle CLI setup).

Here the output of particle setup:

Wi-Fi Network: ASYD_2
Password: xxx
Security: WPA2 MIXED

? Would you like to continue with the information shown above? Yes

Obtaining device information…
Requesting public key from the device…
Setting the magical cloud claim code…
Telling the Photon to apply your Wi-Fi configuration…
The Photon will now attempt to connect to your Wi-Fi network…

However after the setup send wifi configuration, nothing happen on the photon, and if I reset it it still in blue led blinking mode (so wifi setup).

Any idea? Is my photon now definitively broken?

Thanks for your help

There is a known issue with the latest (0.4.4) firmware that causes listening mode to give up connecting to the wifi network quickly and go back to listening.

A simple workaround is to reset your photon, it should then come out of listening mode, and try to connect to the WiFi network you previously configured.

By reset you meaned push the reset button? If yes, as far I can tell it restart in wifi setup mode (aka blue led blinking).

By the way, I changed the server key and server URL using the particle-cli.

Can you confirm the following command should restore as factory defaults?

wget https://s3.amazonaws.com/spark-website/cloud_public.der
particle keys server cloud_public.der

Yep, that command will reset to the public key for the cloud, but I recommend you hold off doing things like this unless you’ve specifically changed keys or seen some other problem that indicates it’s necessary - more tweaking means potentially more chance of breaking something! :wink:

Can you try something for me. Use particle setup wifi, choose N to all the questions, and just enter random values. e…g abcd for the SSID, and unsecured for the type.

Also please put the device in DFU mode, and flash tinker:

particle flash --usb tinker

On reset the device should blink green (forever, since it cannot connect to the network given.)

This test is just to show that the device can function normally.

Cheers,
mat.

Thanks for your response!

I’ll try that but later :slight_smile: I successfully restore the behavior I want (Aka the photon try to communicate with my python server, but I now have some protocol errors but it’s another story)