Can not factory reset photon

I have been having a few problems with my photon. I tried to add a new WiFi connection to it by holding down the setup button, when I did it showed it was in listening mode and then I tried to connect to the photon using the mobile app and I got an error that it can not connect to the device. It told me I needed to reset my photon and then try it again. I tried to factory reset it as they describe in the particle documentation but when I release my finger from the reset button and continue to hold down the setup button the device blinks for a very long time. I held it down for about 2 minutes before I gave up. How long am I suppose to wait for it to factory reset?

There’s no factory reset on the Photon…

Do you have CLI installed?

If you install the Particle CLI, you can run these commands to effectively get a factory reset:

  • particle update
  • particle flash --usb tinker

Holding down SETUP for 10 seconds will erase Wi-Fi credentials :smile:

Do you have a link to this, I’m interested to see that?

It also slipped my mind that you can use Safe Mode, if you just flashed a bad app to your Photon.
https://docs.particle.io/guide/getting-started/modes/photon/#factory-reset

Here is the link to factory reset the photon
https://docs.particle.io/guide/getting-started/modes/core/#factory-reset

FWIW, I had the same issue the other day. I couldn’t do a factory reset the way the documentation describes it. I held the buttons for more than 5 minutes. Nothing.

I managed to get back into a working state by putting my Photon in Safe Mode. That stopped it from running the firmware I had uploaded (which was causing the problem) and get connected to it via the CLI to reset it.

@garyjamjohnson @Wedgie

###Please note that the Docs have different views depending on which device you select here:

###The one you linked to is only for the Core:

###While this Photon shows there is no Factory Reset mode:


##Expert Mode, Engage :rocket:

###In actuality there is a Factory Reset mode on the Photon
…but you have to add your own User App to this factory image location before it will work. It will not restore the System Part 1 and 2 though, only the User part. You can put the Tinker app there with the CLI and your Photon in DFU mode over USB like this:
particle flash --factory tinker

1 Like

Have a closer look at the link you posted :wink:


Oops, Brett had already pointed that out :blush:

1 Like