[maybe solved] Photon: strange behavior

Hi,

my new Photon behaves really strange since yesterday. I cannot set the wifi credentials via the Particle app:

Setup process couldn’t disconnect from the Photon Wi-Fi network. This is an internal problem with the device, so please try running setup again after resetting your Photon and putting it back in blinking blue listen mode if needed.

I was able to flash https://github.com/spark/firmware/releases with the local DFU-UTIL method but it didn’t solve the problem.

I got “File downloaded successfully” for both parts.

Is there anything I can do to get my Photon working again?

Edit: I really don’t know why, but suddenly it seems to be working again after hours of try and error

The problem you saw might be an issue in the 0.4.4 release that causes the device to stay in listening mode after getting Wi-Fi credentials. The workaround is to press reset after you’ve given the device credentials (either via serial, particle CLI or a phone app), to reset and the device will attempt to connect as it should do. This issue has been resolved and will be released next week. Sorry for the trouble this causes.

2 Likes

pressing reset works for me :slight_smile: thank you very much!

I’m having a similar issue with a Bluz USB Gateway (not the shield). It appears to be a sealed device and @eric indicates there is no Reset button–only a Setup button. Any thoughts on how I might get past the WiFi issue (staying in listening mode after it has WiFi credentials)? I’ve tried both CLI and Particle app, but with no success.

Particle identify indicates it’s running 0.5.1

If the Bluz USB gateway uses the same code as the shield gateway, there’s some weird logic in the code. If it ever fails to connect to the Particle cloud for more than 60 seconds, it goes into listening mode (blinking blue) using WiFi.listen(). I took that line out and made it retry instead and it works much more reliably for me now.
Edit: I just noticed that bug is fixed in the current code. I was running an older version.

@rickkas7, I don’t know if it uses the same code and I guess I don’t know how to tell. I purchased my USB gateway about a month ago. I almost wish as a standard practice, there was a published variable that indicated the application code version. I use this technique at times so I know which version of code is running on each device.

@rickkas7, I’m still having the same problem. How do I flash new code if I can’t get it into DFU mode? There’s only a Setup button on the USB gateway. It’s eternally in Listening mode.

I have used the technique from MDMA, i.e. pressing reset after passing credentials from the CLI, on a Sparkfun Photon Redboard and works a treat.