Photon alternating white and d7 leds

One of my Photons wouldn’t complete the wifi setup via either usb or the app so I ended up resetting it not knowing about the firmware issue. It didn’t seem to have an issue but the device would get stuck in listening mode and not save the wifi setting.
I’ve tried flashing the firmware but now the only mode that works is DUF. Otherwise the led just flashes white and alternates with the d7 led:

Any suggestions on what I can do to fix it? Thanks in advance.

Can you install Particle-CLI, place the device in DFU mode and perform a particle update then try particle setup?

Thanks for the reply.

The update command ran successfully however the device reboots with the same led pattern as before. Setup isn’t able to find either a usb or wifi device and the only mode that works is still DFU.

Can you hold the SETUP button until the Photon blinks blue rapidly to clear wifi credentials? It should now enter Listening mode for you to send in wifi credentials

I’ve tried clearing the wifi credentials but if i hold the setup button then it just starts iterating through the different mode options (safe, DFU, etc). I figure this is due to the device resetting every second.

Dont hit the reset. Simply power up then press only the SETUP button.

I didn’t hit reset, the device is resetting itself every second or so when powered on.
This was taken when the unit was powered on:

I’m sorry to say but it sounds like your device is locked in that state. That’s why we have pinned advice to avoid factory reset on the photon. Do you have access to a jtag programmer?

I do have access to a jtag programmer and I’m happy to try any suggestions you have.

That’s great. Then we can definitely get your device out of this state.

I’ve uploaded the latest bootloader for the photon to

Please use your jtag programmer to flash this to address 0x8000000. If you need guidance with this, please let me know what programmer you have, and I’ll provide step by step details.


1 Like

Awesome! I don’t mind reading instructions for this :slight_smile: I have a usbjtag nt.