So I am now having TONS of issues,

I have tried following the steps in this

And NONE of them work as stated, NOT A SINGLE ONE WORKS!!!

I cannot hold the SETUP button and get it into listening mode.


To erase the stored wifi networks on your Photon, hold the SETUP button for about ten seconds, until the RGB LED blinks blue rapidly.
You can also reset the Wi-Fi networks by holding the SETUP button and tapping RESET, then continuing to hold SETUP
 until the light on the Photon turns white. (This differs from the Core.
 Doing this action on the Core will result in a factory reset.)


My photon turns on and breathes cyan, then goes to breathing GREEN.

No MATTER WHAT I DO, I cannot get it to setup, I have unclaimed the device and tried to setup from particle-cli, a meteor softap, NOTHING works.

I don’t even know how to get dfu-util installed, what do I do now?

My computer is UBUNTU 14.04 and it worked fine 3 days ago.

I do wonder this, why does it recognize it in serial in the console, then I have to connect to wifi, why can’t it just CONNECT in the CLI to the photon that way, This step is LITERALLY NOT HAPPENING for me.

This is the MOST frustrating thing I have ever dealt with, it worked one day, now it doesn’t.

Anybody have any directions I can CLEARLY follow, like how to install this silly DFU-UTIL that isn’t just INCLUDED IN THE CLI #1, and some clearer directions to flash new firmware in the terminal since this is seems like its going to be a common occurrence already.

Put your device into Safe Mode and try the SETUP business again

It sounds LIKE you have SOME code on IT that BLOCKS the CLOUD connection, which causes IT to go into BREATHING green. That is EXPECTED behaviour, and most LIKELY a RESULT of your CODE.

NOT being able TO erase credentials MIGHT also have SOMETHING to do with your CODE.

An ERROR descriptions would HAVE been very NICE. Saying it doesn’t WORK isn’t too DESCRIPTIVE, and HARD to debug. Does the CLI give you an ERROR? What do the LEDs do?


Because that is the DEFAULT behaviour. If you want to CONNECT over SERIAL using the CLI, then you SHOULD use the CORRECT command: particle serial wifi, rather than particle setup.
Also, WHAT is ‘LITERALLY NOT HAPPENING’? Again, an ACTUAL description of the ERRORS would be more HELPFUL than ‘it DOESN’T work’.

THERE are VARIOUS topics on this on the COMMUNITY, as well as some HELPER tools, one of WHICH I just LINKED you to.
Also, you CAN’T ‘just INCLUDE’ things in YOUR random program that MAY have been LICENCED.

Once YOU have the CLI and DFU-UTIL installed, you SHOULD be able to do particle flash --usb firmware.bin. So FIRST try to get THOSE up and running.

In the short term, go with @ScruffR’s suggestion. Place the device in safe mode and try setting it up again. Once that’s successful, I’m going to assume it goes breathing cyan, and then breathing green again. If that happens, place it in safe mode again, and once it’s breathing magenta, try flashing ‘blink an LED’ or ‘tinker’ to it. See if it then stays breathing cyan.

WASN’T that much MORE pleasant to READ than with all THOSE random CAPITALIZATIONS ;)?


Safe mode can NOT be achieved. The device buttons are IRRELEVANT, they DO NOT work as advertised on this board, they do on others, not this one.

All variations of button commands end in solid GREEN Led.

Can you shoot a video of the attempt to enter Safe Mode?
Hardware faults are not likely but can happen and Particle is quite good in handling faulty devices (if it is)

No ranting required!


Ended up using Po-Util.

Problem persists after DFU mode and Firmware Clean and Flash, at a loss at this point.

For reference, there is NO output when using the ‘po serial’ command, blank terminal.

How is it that if I give it FRESH FIRMWARE, the problem persists? Listen mode, Wifi Listen etc, not a SINGLE button command works as advertised on the docs.

At this point I am more inclined to scrap the board then waste anymore time with it, spent HOURS following every direction given, not a SINGLE one works, DFU, fresh firmware, nothing, still just same GREEN LED.

Nevermind, just ignore what I said above - since nothing works anyhow

1 Like

Answering a question or two regarding your problems might not be bad either. Alternatively, you could just ignore our advise, be mad, use some more EXCLAMATIONS, and ditch the board. Up to you.


Hey there @Cloud – I’m sorry to hear that you’re having issues.

It seems like the biggest issue is that you’re unable to put your device into listening mode (flashing blue) or DFU mode (flashing yellow). Would you post a video of yourself trying to configure the device into either of those two modes? If there’s an issue with the physical buttons on your Photon, then we’d be happy to replace it for you.

1 Like

Would this be the “Green Breath of Death” that many users are reporting?

Here’s my 2 cents. Try to fix your Photon by following these instructions:

  • Update your version of po-util by doing po update.
  • Then try using po photon upgrade to flash new system firmware to your device.
  • Then use po photon setup to get your Photon online.

If the buttons on the Photon are broken, you will have to use a Mac to put the Photon into DFU mode, because Ubuntu does not support the default Particle DFU baud rate of 14400. If your buttons are truly broken, and you have access to a Mac, I can give you the full instructions on how to fix your Photon so that you can use it with Ubuntu.

This absolutely saved my life. I wish I found this hours earlier. Thank you!!!!!