Flashing green, can not connect

Have two core’s but have only managed to get one of them connected.
I use them on the same Wifi and have restored and reconnect the working one a couple of times.

The one that I’m not getting to work have been reflashed with firmware.
I have tried both the phone app and usb to set the credentials on my network.

Resetting the core sets it in flashing blue state.
Using the application changes the blue to green flash.
But from here I get nothing more.

Any ideas?

Hi @mippen - have you completed the troubleshooting guide and reviewed the documentation specifically for ‘flashing green’?


I’m in the same boat now. When I first got the core it would always come back after getting Flashed. Even after I’ve done a factory reset multiple times and tried getting it back up with the Tinker App, I get the flashing green once I put in my SSID and password.

FWIW I’m using an Airport Extreme with 2 other Airport Expresses to extend the wi-fi network. I’m in the office where the main Extreme lives about 10 feet away from the core.

Also if it helps at all any, I can sometimes get it to connect by hitting the reset button a random amount of times. Sadly even after it connects it goes back to the green flashes within a short amount of time. (at the time of this edit it’s now pulsing cyan with the default tinker app on there… I’ll see how long it stays up before trying my custom code)

edit: it’s still going strong… Going to try my code now…

Nope, flashing green, but 2 reset buttons pressed and it’s back to throbbing cyan again.

All the while the core hasn’t moved at all :-\

edit2: nope, back to flashing green again… sigh.


Todays testing:

Created a new wifi hotspot without password. 2.4Ghz.
Using another power supply, 2.1 A.
Using spark app on android.

Video showing result:

Going true the troubleshooting,

I sit close to the wifi
I have a good power supply
The core has it’s own antenna (visible on video?)
I do not have any splash screen on my wifi and removed passwords
Reprogramming the core = clearing its memory??

The last thing I test is to download the cc3000 patch bin.
Seems to get some kind of error…

dfu-util -d 1d50:607f -a 0 -s 0x08005000:leave -D cc3000-patch-programmer.bin
dfu-util 0.7

Copyright 2005-2008 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2012 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to dfu-util@lists.gnumonks.org

Filter on vendor = 0x1d50 product = 0x607f
Opening DFU capable USB device… ID 1d50:607f
Run-time device DFU version 011a
Found DFU: [1d50:607f] devnum=0, cfg=1, intf=0, alt=0, name="@Internal Flash /0
Claiming USB DFU Interface…
Setting Alternate Setting #0
Determining device status: state = dfuERROR, status = 10
dfuERROR, clearing status
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 1024
No valid DFU suffix signature
Warning: File has no DFU suffix
DfuSe interface name: "Internal Flash "
Downloading to address = 0x08005000, size = 23216

File downloaded successfully
Transitioning to dfuMANIFEST state
Error during download get_status

Hi @mippen,

Cool, don’t worry about the “error during download get_status” at the end that’s normal right now.

Make sure you’re holding down the MODE button on the core until it starts flashing magenta after you’ve flashed the patch programmer to start the patching.



After holding mode and running the upgrade I was able to connect the core to the wifi and the cloud.
Thank you all for tips and trix.

1 Like

When testing to write down the test application, blink led, it goes back to orange flashing.
Only way to return to “normal” after this is to reflash the firmware again.

Any ideas on what is happening?

Video showing led when flashing test application:

Hi @mippen,

It looks like it’s flashing yellow after an over the air flash. Can you look at the back of your core on the flash chip: http://docs.spark.io/images/core-flashchip.jpg , and see if any of the pins are lifted up off the core?

Typically I think this kind of error indicates a bad region of memory on the flash chip – e.g. it download the software, tries to copy it over, and runs into errors, and drops back into dfu-mode since it doesn’t have good firmware anymore.

The other way to test this is to copy some data into that region of the external flash and read it back and make sure they match. I think the address in this case would be 0x40000 and 0x60000

So something like:

####grab this firmware:


####write it to your OTA region and backup regions:
dfu-util -d 1d50:607f -a 1 -s 0x00040000 -v -D core-firmware.bin
dfu-util -d 1d50:607f -a 1 -s 0x00060000 -v -D core-firmware.bin

####read it back to disk:

dfu-util -d 1d50:607f -a 1 -s 0x00040000:68216 -v -U firmware_backup.bin
dfu-util -d 1d50:607f -a 1 -s 0x00060000:68216 -v -U firmware_ota.bin

####compare them:

cmp core-firmware.bin firmware_backup.bin
cmp core-firmware.bin firmware_ota.bin

I’ll be adding this check to the command line tool as well, to make it easier to identify.


When I read up the memory both of the files are blank.
So I guess there are either a faulty memory or a bad connection between cpu and memory?

Yeah, sounds like the flash might be bad, or there might be a bad connection. It sounds like we’re already sending you a replacement for this one?

Yes, have been in contact with Will and should be up on the “Replacement Core Program”.

1 Like