Unable to connect wifi

I got three spark core, and one of them can’t connect to my wifi router.
My router is Cox linksys E900.
I tried every channel of wifi, network mode is mix mode

If it is only 1, then most likely the network is ok.

You might want to try downloading the CC3000 patch on the core and try again.

What’s the exact status? Blinking green? Blinking red/yellow?

If we know the status we can tell better :slight_smile:

@Kechen, how did you provide the WiFi credentials to the Cores?
If you did it via Smart Config (e.g. Android/iOS app), have you tried to set up all three Cores at once, or one by one (having the others powerless)?
If you did it parallel, the “WiFi noise” might have prevented the third to pick up.

Try it one by one or even better USB instead of Smart Config.

Does the stubborn Core connect to another network - e.g. Smartphone hotspot?

It keeps Blinking green

I set up all these three core separately one by one. For this non-working one, I tried both smart configuration and USB method. Still not working, keep blinking green

Mentioned the solution above.

Use DFU-util and download the CC3000 patch :slight_smile: