Unable to connect to wifi

I’ve got 2 spark cores and neither of them would connect using the Spark app on Android. They start out blinking blue and then when the app starts up and I hit the connect button, it goes solid blue for a sec and then to flashing green. My android phone is connected to the wifi and I have had a twine connect ok. (In addition, I’ve got a macbook air connected via wifi and an Ubuntu Linux thinkpad x40 laptop that connects fine).

The router is an Actiontec Model MI414-WR Rev E (got it about 3 years ago when I signed up for FIOS)

Hi @philtor - have you tried the troubleshooting steps in the documentation?


1 Like

I had similar issue and was about to update the firmware as part of the troubleshooting. But in my case I got both my two “faulty” cores to connect by changing my wifi channel from 13 to 6. My cores were stuck at flashing green but both connected instantly when the network channel was changed.

Yes, I have done the factory reset procedure.

1 Like

Hi @jon,

Thanks for posting your findings! Because this Wifi device is using a North America Wifi radio, it is constrained to the usable channels in the united states. http://en.wikipedia.org/wiki/List_of_WLAN_channels – just a friendly reminder to others to make sure you’re not using channels 12, 13, and 14

Given you suggestion, I tried 11, 6 and 3 (doing a factory reset between each). No luck. (Oh, I also went to GoodWill and picked up a Netgear WGT624 v2 for $3 and tried with it… also no luck)

Hi Philtor,

I hadn’t had a chance to reply to you yet. :smile:

Just some quick sanity checks – can you make sure you have a ‘chip’ core and not a ‘u.fl’ antenna core? (I know I’ve forgotten to check this at times). Make sure you’re not using WEP security on your network, and it might be worthwhile to clear your saved profiles on your core: http://docs.spark.io/#/connect/troubleshooting-step-3-reboot-and-clear-memory

The CC3000 patch program can help update the driver on the wifi radio (although this is applied during manufacturing), and the latest firmware includes improvements for configuring certain WEP networks.


Oh, wait, you mean we’re NOT supposed to be using WEP? What should we be using? Because the spark app does ask for a password.

Hi @philtor,

Community members have had really good luck with WPA, and WPA2 networks which are encrypted more strongly than WEP (which is officially deprecated http://en.wikipedia.org/wiki/Wired_Equivalent_Privacy ).


Ok, I’ll give WPA a try. For the record, I found that the Netgear had a “high bandwith” (108Mhz setting) which I turned off, but that still didn’t help.

Cool, good idea turning off that mode :slight_smile:

Ok, I definitely get further this time. I get to the “Breathing cyan” (after the blinking magenta), however the Android Spark app says “No cores found”.

(BTW: it would be nice if the Android app had the option to show password - Nobody is going to see me typing in this password in my house)

1 Like

Hi @philtor,

Awesome! I’d added that suggestion to our mobile app feature backlog. When your core connects to a network it sends out a broadcast packet with it’s core id. The mobile app is looking for this when it tries to claim a core, so resetting your core while trying to claim might help it catch this. Otherwise you can claim manually http://docs.spark.io/#/connect/claiming-your-core


Any idea what the best way to connect to the core via USB on Linux?

Hi @philtor,

After you get your core connected and flashing blue, you just need to know which device file it’s using.

show recently connected stuff:

dmesg | tail -n 50

I’m a fan of minicom, I think the command is something like:

minicom -D /dev/ttyACM0 -b 9600

where “/dev/ttyACM0” is the device file. It’s different on different operating systems and whatnot.

As it turns out, I tried your reset suggestion and that worked. Thanks.

1 Like

Thanks. You are absolutely right of course Dave,

…but I don’t think users automatically think of this (or even know it, I know some channels are limited but I don’t know from the top of my mind what channels in which countries). Most routers these days “auto setup” (for user friendliness) so if the Cores, as I don’t think of as a North American product only, have a restriction in what WiFi channels it uses it should be clearly documented because it’s going to be quite a common problem in some countries.

Therefore Spark Team, please add checking the WiFi channel part of the troubleshooting section before downloading new firmware and such.

@jon added to docs, thanks!

1 Like

I reflashed my core tonight until I realized it cant be used on channel 12. This is a serious stopper for me, because the lower frequencies are totally clogged over here.
Is there no way to release a radio patch for european users to make channels 12-14 available? For me it does not even connect on channel 11 :frowning: