WiFi issues demystified (i.e. Flashing Green nightmare)


received my 2 Spark cores today, thanks. Very professionally made, looking great, website instructions also very clear. Great stuff.

Spent hours trying to make it work but I was always stuck with flashing green LED (ie can’t connect to WiFi). I was experimenting with various settings, but nailed it down to a following, when it finally stopped flashing green and started working properly:

SparkCore only supports:

  • 2.4GHz WiFi (no 5GHz support)
  • 802.11b/g network only with 20MHz channel bandwidth (ie no N or AC)
  • Channel numbers up to 10 (why?!)

Thankfully I have a router (ASUS RT-AC66U) that could independently configure various separate SSIDs, so I don’t have to downgrade the whole home WiFi system just to make SparkCore work. But there might be users, that don’t have the access to settings or a knowledge how to change them. The only working SparkCore WiFi config is Legacy b/g 2.4GHz manual low channel number, which is frankly very basic and might cause problems to quite a few users working in much more modern environment.

Please include this limitation in your specifications and update the WiFi Setup and Troubleshooting sections. It will save hassle to a lot of people.

Many thanks and keep up the great work.


1 Like

Hi @Phantomski

Thanks for posting your findings! We do mention the 802.11b/g limitation on https://www.spark.io/ (under tech specs), and on our docs under troubleshooting http://docs.spark.io/#/connect/troubleshooting , and on our hardware docs: http://docs.spark.io/#/hardware/subsystems-wi-fi-module .

Because this Wifi device is using a North America Wifi radio, it is constrained to the usable channels in the united states. http://en.wikipedia.org/wiki/List_of_WLAN_channels


Hi David,

thanks for your reply. I think the channels limitation is quite an important one and is missing from your specifications. Most of the routers would be factory auto configured to a channel roaming. Whilst it might be ok in US (routers are probably sold with the same limitation) it’s very different story here in UK. Quite a lot of households are now getting N/AC 5GHz routers as part of their broadband update which further increases a likelihood of initial setup problems for a lot of people.



Hi David,

Great point! I’ll add that to our documentation bug list. – I was just thinking 802.11 b/g, and not the channels specifically.


1 Like

Added to docs!


1 Like

I was able to connect before, then I got a new router and now I have this flashing green problem with all three of my cores. Dug into my router settings, I think everything looks ok but is there some setting I could still tweak here to make it work?

Hi @spongefile

The only thing I see that I would try 802.11n mode Auto. I am sure you want your n-capable device to get n-service, but just for debugging I would try turning n-mode off and see if that is the problem or something else.

Thanks, tried that now, unfortunately no change. Do you know if there’s a way to buy/connect an additional wifi access point to a router like this (Thomson TCW770) that could be “downgraded” for the Sparks to use?

Hmm. Just tried to get Spark to connect to my iPhone acting as a hotspot (Spark app on phone not running, put credentials in via CoolTerm) but that isn’t working either. Next will try going to some random cafes with wifi and see if I can get them working there.

Hi @spongefile

One more thing you could try is opening up port 5683 on the router for the Spark cloud connection. I am not sure you are getting that far.

You can add another router downstream of your cable-modem router, using one of the Ethernet ports.

Try turning off n-mode and with the bandwidth to a lower band and see how it goes

1 Like

Hi @spongefile,

Make sure your security mode matches what you’re entering on your core (WPA2, etc) as well.


Tried all of that now except opening port, which I don’t know how to do. Will ask a more wifi/router savvy friend for help on that.

1 Like

You won’t need to port forward unless your core is blinking cyan :wink:

1 Like

Sparks work fine on local cafe wifi, so the problem is my probably overcomplicated home set up.
For the record, this is what I’ve got:
Thomson TCW770 (router with its own wifi, lowest possible bandwidth is 2.4 Ghz)
Airport Extreme (connected via ethernet to Thomson)
Airport Express (connected via ethernet to Thomson)

Wondering if these are interfering with each other, or if none of these can offer 802.11b/g? I’m reaching the limits of my current networking knowledge here.

1 Like

Which router is connected directly to Internet?

You can use that to connect the core to the spark cloud :slight_smile:

If you can get it from listening mode (blinking blue) to blinking green, the wifi network is able to communicate with the core.

We can then move on to see what’s the problem to connect to the cloud

Thomson is connected directly to net, and that’s the one I’ve been trying to connect to, change the settings on, etc. Have rebooted all three cores, used USB and CoolTerm to put in the SSID and password on each, put them right next to the Thomson and waited for ages but they never get past blinking green. Doesn’t the blinking green mean it isn’t getting past trying to connect to the WiFi?

I have a similar setup with an ISP-provided cable-modem/WiFi router and two lower level WiFi routers cabled to it over ethernet. I have actually disabled the ISP router’s WiFi and rely on the lower level routers for all WiFi connections.

The key for me was using WPA2, which has been very reliable.

Newbie. Just received my Spark after a long wait. Cannot get past the flashing green nightmare. Have changed the settings on my router as per above. All my other wifi devices working fine. Where do I go from here?

I had the same problem - just flashing green. I only found out what the problem was after attempting to connect via serial interface (downloaded serial driver, set-up serial comms). After issuing the ‘w’ command, the core asked for SSID and security type…it’s at this point that you’re advised it doesn’t work with WEP doh!
After changing my router to WPA/WPA2 no problem at all - I think this fact needs to be made clearer.

Also a good idea to factory reset before you try something new.


I have tried my Spark on two different wifi networks with varous settings but cannot get a connection. Just get flashing green led. I wish there was some way of telling what the problem is.