Can´t conect to wifi


I can´t connect my core to my wifi. It tried it next to the router but wasn´t able. My spark core is a black one, just arrieved.

1.If your core is** u.fl**, make sure the antenna is on

2.Be in good proximity with the router. Best to be right beside!

3.Perform a factory reset and send Wifi Credentials. (Make sure you get past blinking blue --> Solid blue)

4.Inform us of the status **of the **RGB Led if you don’t see breathing cyan

1 Like

Hi @sparklingdevil,

Just thought I’d link to the troubleshooting documentation in case it helps!


1 Like

I´m sorry. Mine it´s atenna core. I was about a meter of the router. I saw de blinking blue, solid blue and finally the blinking green. After a minute or a couple, the app said “no core found”. As I said mine it´s a black core. I´ve installed the version 2 of the firmware.

What can I do? Many thanks!!!

Back to Question 1,

Is your Antenna on? :smiley:

Do you mean connected? my core isn´t the *u.fl, I have the ceramic antenna core :wink:

1 Like


Moving on!

  1. What is your Wifi security type? (WEP, WPA, WPA2)

    • Can you try using WPA?
    • Make sure the SSID and password contains no funky characters
  2. Set your Wifi Mode to b/g or g and not Auto

  3. Check that your Wifi Channel is 11 and below

1 Like

Ok. I also saw that my channel is 12… It must be 11 o lower, mustn´t it? I´m using WEP. My router isn´t Wifi n


Opps. Sorry i left that out!

Yeah. Channel 11 and below with the default settings. :smiley:

@peekay123, i’ll let you take over from here. Going offline now.

I´m trying both changes channel and security type! Many tahnks kenneth!

@sparklingdevil, let me know if things are working with the changes :smile:

Now it´s breathing cyan, but I can´t connect the app. I´m not sure if the de security type is WPA yet, I´m testing it. I´ll let you know! :slight_smile:

Well… channel 11 and security type in WPA. Breathing cyan in my core… but the APP sais “No Cores found”. I´ve done it next to router… 1 meter.

What should be the next step???

@sparklingdevil, when you say the “APP” do you mean the Spark app? Is it running on IOS or Android? Is your phone connected to the same wifi router?

Yeah at all. I don´t how… but is all working… thank you for all people… very many thanks!!!


I could use de the Spark App… but after put my SSID and my password… and it doesn´t get de core… but it allowed me to “continue anyway” or “try again”… Once it allowed, but after that I disconnected the Spark App and let the Core running. Half an hour later I tried to connect… I could start de App… but the App shows ther 404 Error…

Some help?¿

Can you see under “cores” of your core is listed?

Yes, but it was in magenta colour. After that I reinstalled the Spark App becaus I did a reflash tinker accidentally (what does it do?), and now my listed core is in green colour but I´m not able to connect to my wifi through the app.


when you say magenta colour, are you referring to the RGB Led on the :spark: core?

You only need to setup the Wifi Credential ONCE.

Can you let us know if your core is breathing cyan on the core RGB Led?


I´ve made a factory reset. Load a program on the Core. The App still says that it didn´t fInd a Core… my listed core is still green, but after 5 minutes… I can use the Tinker, but my listed core is still green…