New core wont connect - I think I have flashing cyan issue

Hi I just received my first core was very excited until I tried to connect it.

Went thru all the steps with the iPhone to connect etc … but I still get the initial blue flashing light.

My router is a Netgear R6300 over a comcast cable network using their Business gateway router.

Straightforward home office setup - nothing fancy.

The WiFi Router runs both a 5Ghz and 2.4Ghz networks

The encryption was set to WPA2-PSK [AES]

When the spark was powered up for the first time I got the steady blue light - and the IOS app found my network - I entered my password and got nothing - NO CORES FOUND and just steady blue flashing light.

I took off all the encryption on the WiFi - still nothing
I changed the name of the SSID - it was set to Mike-5 so I changed it to Mike5 (without the dash) … still nothing - on the app - I get no cores found …
BUT the Core started flashing green !!! even though the app couldn’t see it.

So what does that mean ? I rebooted it - its now come back to flashing cyan but my iphone app still doesn’t think the core exists.

Soooo now I thought I’d try Putty - downloaded that
also downloaded the .CAT and .INF file you have as drivers - I right clicked the .INF file to install the driver and I get a message that says “The INF file you selected does not support this method of installation” - I have a regular Windows 7 PC.

After more searching around on the spark web site I came across the statement that i might be suffering from the “Cyan Flash of Death”

Is that the same problem Im now having with my WiFi connection ?

What do I do now ?



Update : Re-booted the core - and it comes back as flashing green. Its plugged directly into my PC’s USB port so I don’t think its a current issue.

Im starting to think this might be a DOA unit. :frowning:

Hey there!

I guess it’s not DOA since you managed a breathing cyan. :slight_smile:

  1. Can you set your router to 2.4Ghz only?

  2. Also b/g or g but not n or Auto

  3. Make sure the Channel is 11 and below too

  4. Also, the range might be an issue since you got to cyan but not on the reboot. Make sure the antenna is on for u.fl

Are you using this at Work with a lot of computers on your network?

You may want to try a factory reset and then connect your Core to wifi using USB.

However, to connect using USB, you’ll need to make sure you get the driver installed first. You’ll probably want to factory reset the Core and wait for it to come back up and blink blue (not cyan) at you. This will let you know it’s in a sort of serial listening mode. Then, open Device Manager from Control Panel (if you have Control Panel set up to show the categories, click on the Hardware and Sound category and then Device Manager from the Devices and Printers section). Once the Device Manager is open, look for a device that is showing some sort of warning/error icon on it. Right-click on that device and update/install the driver. You may have to manually specify the driver location and point it to where you have the .inf and .cat extracted. Hopefully, that should get the driver installed with less fuss.

Disclaimer: I am slowly forgetting how to use Windows 7, so I’m kinda shooting from the hip on this one.

1 Like

No its at home - 5 computers

Could you troubleshoot with this and let us know which step you are stuck at? :wink:

OK after some playing around with my router I can tell you what it isn’t

It isn’t a range issue
It isn’t a low power issue
its not even an AES encryption issue.

How do I know all this - because after a factory reste - I did actually get it to connect thru my iPhone.
How ?
All I ended up changing was my SSID from Mike-5 to Mike5

It seems that’s all it needed was an SSID without a (dash) - in it.
Can that really be the cause of this issue ?

I’m happy you got it working!

If you don’t mind, can you try using an SSID with a dash and test again?

I will do a test when have a router which I can change SSID name :slight_smile:


Just wanted to pop by to say that i have tested with SSID: Mike-5 and it worked well :smile:

I just realized today that one of our wifi networks at work has a dash in it, and I have no issues connecting to it. It uses WPA (not WPA2). I factory reset one of my Cores and punched in the wifi credentials and immediately thought of this thread!

I got it working on WPA2 with dashes as well :smile:

Thanks @wgbartley for chipping in !

Mine doesn’t work with the dash - it only works without the dash - its the weirdest issue - i will run more tests when I get some time next week. Thanks for all yr input.