Wifi Connectivity issue: Blinking Cyan

We want to use Spark’s around the office, but aren’t able to get them connected to the cloud - the Core accepts the SSID and password (both from the iPhone app and serialling in) and then breathes cyan (for 40 seconds) with flashing cyan (for 5 seconds). We can’t upload code, however, from /build or play with Tinker (it connects, but times out when you try to play with the pins).

The Spark works brilliantly on my home WiFi, just not at the office.

The office WiFi is WPA2-personal and we haven’t had any troubles connecting other devices.

Does anybody have some ideas?

Malte

@malte,

Flashing cyan means it’s connected to Wifi but unable to reach the :spark: cloud.

I have the same issue in school. If the IT dept is willing to unblock the COAP port 5683, it should work perfect :slight_smile:

1 Like

@kennethlimcp Aha! Thanks so much for your quick response! I’ll have a chat with them and see what we can do.

I’m excited!

1 Like

Could you change the title to maybe `Wifi Connectivity issue: Blinking Cyan" to better reflect the problem to users with similar issues?

Thanks! :wink:

I’ve discovered that bribes work pretty well in influencing firewall changes. :wink:

1 Like

If it’s breathing for a bit and then disconnecting, this issue might just be the result of a very busy network. We’re in the process of rolling out a stability update for the cc3000 that will help it to be more stable on noisy networks. We should have that out within the next week.

If you wanted to flash a version over DFU manually, there is a preliminary update here, but I might recommend waiting on the full update since we’re so close: ( install cli and dfu-util -> https://github.com/spark/spark-cli , spark flash --usb cc3000 )

Thanks!
David

3 Likes

Hi, sorry for reopening the old topic, but just bought a new core and it won’t connect to the cloud, blinking cyan all night long. Another core in the same network connects in one second. Already made a deep update with

spark flash --usb deep_update_2014_06

but still blinking cyan.
Also tried another wifi network, no difference.
Also tried android app, ios app and usb spark setup.
Is there anything else I can do ? Any new update ?
Core is new, shoul’nt need any updates…

1 Like

Blinking cyan sounds like it is connected to Wifi but not to the :cloud:, does it perform a few red flashes after some time?

I saw it once, yes. But it was after very long time of blinking cyan. Turned it off/on, and is blinking cyan as before.
This is a new core, the only code it has is tinker.

Agree that it should not be behaving that way.

Do you have spark-cli installed?

I would like to reflash the :cloud: public key just to be sure followed by changing keys if you don’t mind the hassle. :wink:

Sure I have.

Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 1024
DfuSe interface name: "SPI Flash : SST25x"
Downloading to address = 0x00001000, size = 402
Download [=========================] 100% 402 bytes
Download done.
File downloaded successfully
Okay! New keys in place, your core will not restart.

I powered it off/on, and no difference.
Blinking cyan like crazy :frowning:

Weird… Since you are an existing core owner… I’m guessing it’s blinking cyan and not green?

Sure it’s cyan. The same cyan it should breath after connecting to cloud, like my other core does.
Normal boot sequence at power on - white, blinking green for a moment, blinking cyan, never comes to breathing cyan.

I don’t know if that matters - cyan blinking is not with the constant frequency - there are two slower blinks and about 10 seconds of fast blinks, repeat.

Not sure what’s exactly the problem. You might want to email hello[at]spark.io to replace it or troubleshoot offline :wink:

Thanks. Already did…
Till now, got the advice to send “a picture of a sad puppy to get extra sympathy from your support agent”…
Looking for the puppy now…