Problem with connection

Hi All,
I just bought a spark core, I followed all the steps and I was able to configure the WiFi and also to register the core. The app did not work, I had to do it with the serial terminal but no problem.

The problem arises after, I got the cyan led blinking. I tried with two routers: D-Link and Apple Time Machine, even considering a channel below 11. I tried with both, switching off the other and I got the cyan led blinking. I am not sure if it is the death problem because it start blinking, it connects, after 10 sec starts blinking, then after 5-10min fixed, and then blink again.

I am not able to use it both with the spark app and programming the core.

Should I upgrade the CC firmware? Anyone with the same problem?

thanks,
marco

You can try patching the CC3000 firmware though it should already have the latest version while being programmed at the factory.

Usually, blinking cyan means the core is unable to reach the cloud. We have also seen cases where the keys were corrupted which can be easily fixed.

That it was I thought, since I just bought, I was thinking the it should have the latest version of CC firmware…

But if I see it fixed for 10/20 sec, doesn’t it mean that it is actually able to connect to the cloud?

Yup! Breathing cyan means it was able to communicate but it’s weird that it ended up with blinking cyan…

Were you able to claim it? I would simply attempt to patch it just to see how it goes since there isn’t really much (IMO) you can do with that issue. :wink:

Yes,
I claimed manually from the console app.

I’ll try to patch, and keep you posted.

I tried with the dfu-util, all the other methods gave me error.
But this seems not to work too…

Look at the results
dfu-util -d 1d50:607f -a 0 -s 0x8005000:leave -D ~/Downloads/deep_update_2014_06.bin
dfu-util 0.7

Copyright 2005-2008 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2012 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to dfu-util@lists.gnumonks.org

Filter on vendor = 0x1d50 product = 0x607f
Opening DFU capable USB device… ID 1d50:607f
Run-time device DFU version 011a
Found DFU: [1d50:607f] devnum=0, cfg=1, intf=0, alt=0, name="@Internal Flash /0x08000000/20001Ka,108001Kg"
Claiming USB DFU Interface…
Setting Alternate Setting #0 …
Determining device status: state = dfuERROR, status = 10
dfuERROR, clearing status
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 1024
No valid DFU suffix signature
Warning: File has no DFU suffix
DfuSe interface name: "Internal Flash "
Downloading to address = 0x08005000, size = 93636
…
File downloaded successfully
Transitioning to dfuMANIFEST state
Error during download get_status

What am I supposed to do?

1 Like

Hi @marco

The good news is the your dfu-util command worked fine! There is an “error” at the end of the dfu-util program that not related to Spark. If you see all the ....... section, your download worked.

1 Like

Hello,
after downloading the patch, now it does not even connect to wifi, it remains in green flashing :frowning:

What can I try?
In this way I cannot use it at all…

I also tried factory reset, and nothing always flashing green…, I’ll try in another location with another router, but I am afraid it won’t work

Please try patching with this file: https://github.com/spark/spark-cli/raw/master/js/binaries/cc3000-patch-programmer.bin

and let us know which step are you stuck at:

[1] CC3000 Patch via DFU-util (windows): https://community.spark.io/t/howto-update-cc3000-via-dfu-util/5665

[2] Spark-CLI on Windows: https://community.spark.io/t/tutorial-spark-cli-on-windows-05-july-2014/3112

Hi,
I tried spark core in another room where I have a wifi repeater, and it works!
So it is definitely the access point.
That confirms my initial thoughts about CC3000, it is not compliant with a lot of access points. I have friends who were developing a wifi-light and they had to change chip due to the problems.

In my case spark does not work with Linksys DIR-615 ver. D3 with the last version of firmware, and last Time Capsule with network 5ghz disabled.
Do you think that trying your file I have a chance that it works?

I would like to ask you a question from a design perspective, maybe @zach can answer , why not to choose a wifi-chip that are used in common smartphone like the one used in Iphone o Samsung Galaxy, that I think they use the broadcom?
I understand they are more expensive, but having a lot of problems with common access points, make the product not usable.

marco

You can try the patch and change the router settings to test again.

There’s plans to use other Wifi module for future development kits but that’s not something i can comment or reveal. :wink:

Spark HQ is definitely aware the CC3000 issues and already been testing other Wifi modules for their R&D. :smiley:

Hi @marco

Don’t forget that even with the 5 GHz side of you router disabled, you still need to be on channel 11 or lower.

1 Like

Hey @marco,

Great question. The Wi-Fi modules that can be used for embedded products (i.e. microcontrollers) are not the same as those that are available for smartphones. That’s because the requirements on the host processor are very different. Broadcom does make embedded Wi-Fi chips (they have a line called WICED), but it is entirely separate from their smartphone line.

In any case, as @kennethlimcp suggested, the CC3000 was a great module when we launched the Spark Core, but there has been continued progress in the industry (as there always is with semiconductor companies), and we are currently testing other Wi-Fi modules for future products.

As far as compatibility, I would actually be pretty surprised to hear that that’s your issue. The router compatibility for the CC3000 is quite good, especially with common routers like Linksys. We have of course heard of many issues, but router compatibility has not been a frequent issue. More likely it has something to do with the settings on that particular router, i.e. 5Ghz, channel >11, etc. Are you in Europe? Are there any settings in your router that are uncommon or different than how the router is delivered from the factory?

Hey @zach,
thanks for the answer. I really appreciate it.
I am aware of the fact that embedded products cannot use the same chip of smartphones, anyway I think that today something better than CC3000 can be found. I totally agree that it was a great choice when you started, and I am really happy to hear that you are testing different chips.

In Europe, I heard from a lot of people I know, designing HW products, that WiFi compatibility is really a pain.
In the specific of my case, I have channel <11, 5Ghz disabled. If you like I can send you over the screenshots of the configuration of the WiFi routers as well as specific model numbers/versions.

Thanks,
Marco

Hi,
I tried also this file, and it does not work.
Also with FritzBox router, I am not able to make it run :frowning:

marco