Unable to connect to the Spark Cloud

I am a beginner. I am trying the very basic example of blinking an LED through the Spark core. I have connected over USB to a Windows machine(even tried it on Mac )

Until now I have successfully completed

  1. the Smart Config & the network information was found.(solid Blue)

  2. connected to the local wifi network( flashing green & then flashing

But, then after Flashing the code, I expect it to turn into slowly breathing cyan & magenta eventually(& LED blinking ofcourse).But, it doesn’t seem to be happening. I have been stuck on this for the whole day.

Any suggestions on how to solve this issue?

means that the core is connected to the Wifi network but not the Spark :cloud:

Do you see your core in the list?

The core should normally be breathing cyan and turn to blinking magenta when there is new code :wink:

There is a lot of good troubleshooting info here:


Yes, I see the core in the list. I saved, verified & then flashing it.

I tried with different wifi networks too.

my question is, is the core breathing cyan? Not the Web IDE response :smiley:

No it is not breathing cyan.
It is flashing cyan (8-10 seconds) -> solid white(1 sec) -> flashing green(1 sec) ->flashing cyan again.

That means there’s some issue with cloud handshaking. Can you try with a Wifi hotspot on your mobile phone just to be sure?

We can attempt to fix it with a patch if this doesn’t work.

Let me know!

Okay. I was trying with the Wifi hotspot using the Android App PDANET+ from my phone until now. It did not work. But, when I used the wifi hosted by the same app on my friend’s phone. It worked ! The only difference being he had the paid version of the app.

Thank you for the suggestions though.

Sounds like some sorting out for the wifi network settings…

Let us know if you need more help :wink: