[SOLVED] So is my hardware okay?

I just got my Spark Core (chip antenna) this weekend. So far I’m having some trouble…

At home: Tried setting it up with my iPhone and it just started blinking green. Reset to factory default, tried setting it up with USB, and it just kept blinking green. I’m thinking it might be because I use WEP at home, but it was too late to try changing the router to WPA. (Is WEP as seriously not usable as the serial connection implies?)

At work: Tried it with iPhone and USB, but all I got was cyan for a sec then the green-to-red blinking. We have no security for wireless here so WEP shouldn’t have been the issue. I reset the memory, went back to factory defaults, made sure port 5683 was open (hooray for being IT), checked the status of the Spark.io servers (up), but never got better than green-to-red.

I haven’t tried reflashing the firmware (ugh) yet so maybe that’ll fix the issue. However, I’m curious if there’s any way to make sure the hardware is working. My package arrived Saturday and was outside in a mailbox until Sunday. I feel like the different flashes (green at home, green-to-red at work) means the wifi is okay, but I’d like to rule that out if possible.


You shouldn’t be seeing green-red flashes if the core is brand new and yet to be connected to the :spark: cloud for the 1st time.

I would say that the hardware is working fine and we can do a troubleshooting. Once we verify that nothing is fixing it, we will arrange for shipping!

Can we attempt to use WEP?

  1. If your core is u.fl, make sure the antenna is on
  2. Be in good proximity with the router. Best to be right beside!
  3. Perform a factory reset and send Wifi Credentials. (Make sure you get past blinking blue --> Solid blue)
  4. Inform us of the status of the RGB Led if you don’t see breathing cyan

Additional points to note:

  1. Simple SSID and password without funky characters (triple check what you entered)
  2. Sometimes, it takes a few minutes or even half hour from blinking green to breathing cyan (according to experience we seen in the forum)
  3. So if you don’t mind, let the core sit for few minutes

That’s good to hear!

I can’t enact WEP here at work, but I use WEP at home. I’ll try it again there when I get home tonight. If WEP doesn’t work would WPA be a good second?

Oh! Maybe I wasn’t being patient enough.

1 Like

Never fails. I just need to ask why something doesn’t work in public forum and it starts working. Thanks!


Every. Freaking. Time.

I think it’s some Murphy rule. I hate that guy.