Debugging blinking green (can't get online)

greetings everyone,

sorry for asking a repetitive question – I’m having blinking green on new spark. I have a huge batch I’m working through so I’m rpretty familiar with updating firmware, etc.

have done:

this spark is acting like the spark we had where we ruined the eeprom by setting the params repeatedly. Is there a way to check the eeprom? or any code for testing an SSID connection that doesn’t use what ever system the ssid core firmware system uses? I just want to know what’s wrong with this spark…

on a side note, here’s our system (https://github.com/firmread/spark-OF-UDP) which sets up a local UDP connection (discovery / heartbeat, etc)… In the center is an openframeworks app that finds sparks and pings them and reports back about health.

here’s a 3d printed platform that houses a spark antenna and adafruit protoboard

here’s a stack of cores which are heading to russia:

I did not see you mentioned about using the CC3000 patch. That’s what I usually recommend for blinking green scenarios.

Give it a try? :slight_smile:

Seems like you have the black cores which should have the latest patch.

I would suggest to turn off all cores and try connecting one first.

Also, do share your network settings with us!

Why do you even have more cores than me?! I feel so naked after handing out 6 cores to people around me!

some I’ve missed this

will give it a try and get back to you. thanks!

The cores are going overseas for a project and staying there, so soon I will go back to just a handful…

1 Like

thanks that did the trick. The other one where we slammed the eerom didn’t work with patch, but the one that couldn’t get online is now online.

thanks again

1 Like

ok out of a batch of 65, I have 4 that are still giving the green blink error after

  • tried different antennas
  • tried router adjustment, diconnecting everything etc
  • factory reset
  • install compiled firmware (as per https://github.com/spark/core-firmware)
  • CC3000 patch programmer

there’s also one that seems sort of wacky, fast yelow red then blue blinking (seems like 20 seconds of yellow blinking 10 secs of red and one second of cyan)

any advice about these stubborn boards?

thanks,
zach

Hmmm… Seems like you got all the stuff covered.

1st thing on my mind is DHCP. or Mac address conflict (which shouldn’t happen but maybe due to the CC3000 patch things get changed)

Another thing is i will only turn on one core at a time for now. At least to make sure they can connect first.

Hope this helps!

Seems like you have the largest :spark: core deployment till date! +10 for that :smile:

ok ! just arrived to venue and will try this… I think we did try one at a time and resetting the router but I’ll try that again. I also want to look at MAC addresses to see if the cc3000 patch worked (I’ve read on this forum that a certain mac address indicates it did not).

thanks,
zach

1 Like