Blinking green [SOLVED]

I’ve tried setting up my core for the first time via the app. It sends it into blinking green mode (iPhone 5, router is 2.4ghz).

Try same thing with USB - same thing, sends core into blinking green.

Tried to get firmware patched - and I get these two errors during make:

make[1]: arm-none-eabi-gcc: No such file or directory
make[1]: *** [obj/CC3000_Host_Driver/cc3000_common.o] Error 1
make: *** [check_external_deps] Error 2

Any idears?

Just popping in here since Justin and I are emailing directly as well.

In the case of this specific error, it would be because the arm-none-eabi-gcc toolchain isn’t installed and in the path, there are some instructions on getting a local build environment setup here:


Thanks Dave,

So here is the latest. Able to install new patch (device goes magenta).

When I connect with my phone, or usb serial, the blinking blue turns to blinking green and stays there.

So - it’s communicating with the core. But it’s apparently unable to connect to the internet? Thoughts?

1 Like


Just wondering when you buy the core? A CC3000 patch should solve the problem.

If you have a u.fl version of the core, you need to attach an external antenna

Solution! I’m not sure if there wasn’t also a firmware patch issue. Regardless, I got things finally working by adjusting my router. This may have been common sense for spark elite. I have an ASUS RT-N56U - I needed to set the wireless mode to g/b NOT auto and DEF NOT n mode.

I wrote up more here:


That’s right!

Sometimes the Auto mode causes some issue :wink:

1 Like