[Solved] My spark goes to flashing green forever

Hello. It has happened to me twice. I get a brand new spark, program it and everything works perfect, But if for some reason the battey drains without charging it. The spark core goes to flashing Green and doesn’t connect to the network.
I tried everything that I have seen here. I have even flashed the core. But still no luck I even took it to a different network
even-though It was working before and no luck. This is the second core that I have the problem. Im powering the core with a sparkfun regulator and battery charger (https://www.sparkfun.com/products/11231). Can someone help me what else can I do to fix this green light problem?
Thank You.

someone had a similar problem not too long ago…

1 Like

Yup. Thats what happened to me. Still no luck bringing them to life. Sometimes it makes me think is a hardware problem)-;
Any help is apreciated.

Try patching it with the CC3000 bin file after a factory reset. :slight_smile:

1 Like

I did it. Nothing yet.

Can you power the core using a USB supply just to be sure it’s not a power issue?

How did you perform the patch?

Im powering the core thru the USB. I did the patch with dfu-util_0.7

Is the patch file from https://github.com/spark/spark-cli/blob/master/js/binaries/cc3000-patch-programmer.bin?raw=true?

Also, you should probably need to key in Wifi credentials after patching.

If you have a mobile with Hotspot feature, try connect the core to it with an OPEN wifi security setting.

Yes thats the same patch I used. And yes I reprogramed it with a open wireless ( no wep key).

That’s weird. :smiley:

How about using the Spark app to send Wifi Credentials? Just to be sure that the core is able to receive Wifi signal

I use the Spark App and nothing. Just stays there with a blinking blue light. the only way I can input the wireless credentials only connecting the usb cable to the comp. I’m going to try again to repatch it to see what happens.

It seems like the core is having difficulty receiving Wifi signal… I guess it’s a antenna version?

Yes. I changed the pigtail cable and the antenna and nothing. It was working before. )-:

Sounds like the antenna might be causing some issue. Check that the connector is not loose?

Also, if you have the Chip Antenna version, we can use that to test the Wifi connection first. :slight_smile:

I did check the connection. Yes I have another sparkcore working right now on the same network

Ah awesome. I had this issue once and took a few CC3000 patches for me to reconnect to the Wifi network again.

You might want to try that out. :wink:

Also, it will be nice to update your factory reset firmware to the latest tinker version just to be sure that that’s not causing some issue. :smiley:

This is the result I get when I flash it.

That looks correct. Did the core blink magenta to indicate that patching is in progress?

Yes. I followed this direction.

Ok great! Are you trying to solve the flashing green problem?

If so, download the patch programmer here:


And the command would be:

dfu-util -d 1d50:607f -a 0 -s 0x08005000:leave -D cc3000-patch-programmer.bin

When the Patch Programmer is installed, the LED should turn off. Press the MODE button for one second to install the Patch; the LED should start flashing magenta.
When the patch has been successfully installed, the LED will switch to solid magenta.

To reboot back into the Spark Core standard firmware, hold the MODE button for 10 seconds while the Core is powering up (as above, to get into bootloader mode). This will activate a factory reset; if it is successful, the LED will flash white, and then the Core will return to its previous state (but with new firmware on the CC3000).

@dave, may I suggest to explore whether it's possible to check the CC300 firmware version somehow? smile I'm not sure if the CC3000 stores it in EEPROM.

It might be really handy when you all roll out the CFOD patch to assist spark owners with issues.

Maybe also useful for production check smile

Now when I flashed it goes to flashing magneta by it self and It looks that reboots by it self and goes back to flashing yellow.