Unable to connect to Wifi (after flashing program)

@Dave Can you please help !!
I have had the spark core for couple of weeks now, it was working perfectly fine (was able to connect to wifi, flash a program etc).

The core is now flashing green (indicating that its trying to connect to internet) and doesn’t progress further. I’ve followed the troubleshooting guidelines with no luck (powering off & on, rebooting the core & clearing its memory, factory reset). I have not changed any of my wifi settings.

Below is the code that I had used the last time the Spark Core was connected to wifi.

void setup() {

void loop() {
    Spark.publish("logging", "pubStr");


I seem that you are opening new threads to resolve the same issue. It will be nice if you stick to one thread and receive help from there.

Otherwise, email the support team at hello@spark.io for more offline assistance.

Thanks! :smiley:

@kennethlimcp I too wish to continue on the same thread, but this is a new problem and not the same issue. Previous thread was regarding a problem of flashing code to the Spark Core from web IDE when there was wifi connectivity to the Spark core. Here I am unable to connect Spark core to wifi in the first place.

Hi @Pravi

I think you are having the continuation of the same problem. I have tried this code (with 1 second and 5 second delays) and due to the bug, it blocks further over-the-air updates very effectively.

I was able to get my core back online by doing a factory reset, after that everything is fine until I run this program again.

1 Like

@bko Factory reset helped me to get the core online many times but not anymore. Doing a factory reset now, doesn’t seem to progress any further than flashing green led.

I would make sure you do a factory reset from power-off and see if that makes a difference. I have also had to do back to back factory resets–I have done a lot of crazy things to my core including over-writing program memory and I have never bricked it! You just need to be persistent.

@bko, do you think applying a CC3000 patch or performing a deep update would help ? (I’ve bought this core about 4 weeks back, so not sure if a deep update would really help).

Cores from 4 weeks likely already have the patch applied but you can’t tell from the outside, only from the software side. The CC3000 patch will help in general but I don’t think it has anything to do with your current difficulties. You would have to apply it over USB if you cannot do over-the-air updates yet.

Hi @Pravi,

I think, generally speaking there’s no problem caused by a firmware you loaded or an OTA flash that can’t be solved by a factory reset. :slight_smile:

Here’s a video that shows the process just in case:

I also recommend switching up your USB cable / power supply if everything else is the same, a bad cable / not enough power can prevent the core from connecting.


1 Like

@Dave, Sorry for the late reply, I saw the factory reset video (several time) and followed the instructions precisely and it doesn’t help. Regarding the power supply connection, I have tried with two cables (including the one supplied by Spark) and it doesn’t work either.
I am not sure what else to do, Can I get a replacement ?

Hi @Pravi,

Hmm, sure, can you email us at hello@spark.io, and we’ll get it figured out there.