Core flashing green and can't restore after undervoltage startup

I have several cores running on solar powered, battery backed up systems.

I have a situation where a battery failed and the voltage dropped to under 3.3v quickly.

When I got to the unit the battery voltage was about 3.2V and the core was stuck flashing the rainbow.

I replaced the battery and turned the unit back on, the Core came up and started flashing green but never connected.

So I removed the core and inserted a new core that is pre-loaded with WiFi credentials and ready to go. The unit started up right away.

I took the flashing green core home and here is what I have done to try and get it to connect.

  1. I factory reset by holding mode button down and resetting, if flashes white then solid blue.

  2. I use the Spark CLI and go thorugh spark setup. It’s not my first time doing this I have done it many many times and know the SSID, WPA types and password.

  3. The credentials are saved to the core and it starts flashing green but never connects.

  4. Next I put the core back in factory reset, it is solid blue and use the Spark mobile app to program the credentials. Same result. The core eventually flashes green and the mobile app eventually times out saying the core can not be reached.

  5. I used dfu-util and re-flashed the core firmware from here

The LED on the core goes out, I press and hold the mode button and it goes to flashing magenta and then solid magenta.

I then go through the setup again, and WiFI credentials are saved to the core.

The end result is the same flashing green LED and it never connects.

What should I do next?

Someone else had this exact problem, you need to do a firmware update in the cc3k that will clear something so it works again. When you do the cc3k you need to flash tinker after

Details in here

Well that totally fixed it.

spark flash --usb cc3000
spark flash --usb tinker
spark setup

I thought that doing all that through dfu-util was the same, but I guess it’s not.

Incidentally, This has happened to another one of my Rev 1 Cores (White) a several months ago but I never got around to investigating what the problem was with it so it sat in a drawer. I just ran through these steps on that core and it is now working again too.

Thank you very much for pointing that out to me.

I wounder what could be going on that is causing this? I am also using the Flashee library and the app running on the core pulls some data from there when it first starts up. I wounder if that is the combination of Flashee and Under-voltage during boot up or read cycle that causes this issue.

1 Like