Flashing green light problem [solved]

I’m trying to setup the spark using Apple airport wi-fi and a u.fl antenna (which is plugged in). When I first plugged it in (USB to an iMac), it went through the sequence of light behaviors ending in “breathing cyan”. But I was not able to connect to it through my iPhone 4. At that point I tried to reset it using the buttons and everything fell apart. Now its stuck at the flashing green stage. I went through the whole dfu flash procedure as recommended to no avail. What now?

Hi @alh, Let’s resolve this together.

  1. Factory reset your Core. Hold BOTH button, release the Reset and wait until the RGB led turns white (blinking yellow --> flashing white)

  2. The core will restart and blink blue.

  3. You can now send the Wifi-credentials using USB or the Spark App.

1 Like

OK, thanks for the reply. After the reset, the light did begin flashing blue. When I entered my wifi password on the iPhone app, it turned to solid blue, then blinking green, which is what its doing now.

@alh did it turned blinking cyan?

May i know the following:

  1. Wifi router type 802.11a/b/g/n?

  2. Wifi Channel No

  3. Wifi security type (WEP, WPA, WPA2)


No cyan, just blinking green. The router is an apple airport extreme base station, about 2-3 years old. I believe it supports multiple protocols (a/b/g/n) but don’t know which ones. Also don’t know the channel number - how would I find out? The security type is “WPA2 Personal”.

Will you be able to login to the airport extreme and take a look?

Doesn’t sound like a router issue since you managed a breathing cyan previously.

You can try to power off then on or press the reset button in the core and see if it connects.

If it doesn’t, try a factory reset again…

Sorry if it’s taking too long for a simple task like that :slight_smile:

Do you know how to do that?


Read my post above and try the steps :slight_smile:

I’ve tried turning it off and on and doing factory resets several times - no luck.

I have Airport Utility opened now and everything seems to be normal. Anything in particular I should look for?

Is there a channel setting? If you wouldn’t mind, try WPA security.

Take note that it’s going to disconnect all the existing devices connected to the network and.

You will need to reconnect to wifi again after the setting change. Are you comfortable moving forward?

Also, do you happen to have a chip antenna :spark:?

Would be nice to see what u.fl antenna you are having.

Blinking green means connecting to wifi but it stopped there so we gotta work on the wifi issue :slight_smile:

I’ve looked for a channel setting, but I don’t see the word “channel” mentioned anywhere in Airport Utility or anywhere else I’ve looked. I don’t mind reconnecting, lets go ahead, but you’ll need to walk be through in detail.

Just saw your second message about the antenna. I checked the connection, and I think it was loose because I got the “breathing cyan”! Tried connecting with the iPhone, though, and still no luck on that.


ALRIGHT did the core blink magenta after breathing cyan?

No magenta. Should I reset?

Try this.

Turn off the app and restart again

SUCCESS! Thanks for your help.

1 Like

@alh can we get a title change? :smiley: hells sounds a little too crazy for our future :spark: core owners :smiley:

Will do. Flashing green light problem OK?

1 Like