Multiple Cores Failing to Connect to the Internet


Yesterday I received two Cores from Maker Shed and immediately tried to set them up (one at a time). Following the “Getting Started” guide, the Cores only ever flash green. One Core has successfully connected to the Cloud, but upon disconnecting it from power and reconnecting it in a different location, it only flashes green. Even moving it back to the original power supply, it still only flashes green. I have since followed the “Connect over USB” guide, but to no avail. Although I am able to input login credentials to the terminal and successfully communicate those to the Cores, neither makes it to cyan. Additionally, I have tried resetting both Cores to factory settings and clearing the memory. Has anyone else had connection problems like this, and if so, how did you resolve them?

Currently, I live in an apartment complex with approximately 15 other networks in range. My router is a Belkin N300 Wireless Router with model number F9K1002v1, transmitting on the 2.4 GHz band.

I have a third Core on pre-order and am hoping to resolve this before that one arrives.

Thank you very much for your help.


  1. is your core chip antenna or u.fl?

  2. what is the channel of your wireless?

  3. you managed to get from blinking blue to solid blue then blinking green and not cyan I suppose?

1 Like
  1. chip antenna

  2. I’m not at home so I don’t know the channel for certain, but I believe it’s 11.

  3. yes, flashing blue, solid blue, flashing green…still flashing green.

@gaudsend sounds like a network/router settings problem for now.

Keep us posted again when you are working on it and we can see how to get it up and :spark:-ing!


Hmm, can you try tweaking the security mode down to WPA, or up to WPA2? Or can your access point host another ssid as a g-only access point?

I just bought a new router this afternoon (Linksys AC1200) as I found the old router was frequently dropping the connection. The new router is, by default, set to WPA2 and is backward compatible with a/b/g/n standards. Both Cores failed to reach solid blue when I tried connecting them today. I’m attempting to change the channel and other router settings on the 2.4GHz band and will update here once I have succeeded/failed.

Is there a particular channel which works best with the Cores?

Any channel 11 and below would be good.

Use WPA instead of WPA2

Okay, thanks @kennethlimcp, I’ll do that.

Okay, 50% success! I set my router to WPA and channel 11, per @kennethlimcp and @Dave’s suggestion. One of the Cores connected just fine; however, the second core started flashing red (two flashes). I checked the internet connection and everything is working fine. I reset the Core and cleared its memory, and now it only flashes blue. I’m going to let it sit over night, un-powered and try again in the morning.

Thank you both for your help so far!

@gaudsend, blinking blue or blinking cyan?

If it’s blue, use the Spark App and claim it. Then you should have it connected!

@kennethlimcp blinking blue (not cyan). And I am using the app…that’s how I connected the first one.

Go ahead and claim the 2nd core :slight_smile:

I can’t. I’m connected to my wifi network on my phone and the SSID displays correctly in the Spark App. I type in the password, exactly as I did with the first core, and hit “Connect.” The core is plugged in to the same wall wart as the first core was and is flashing blue. It never reaches solid blue…just continues flashing blue.

Is there another way to claim the core? Why would the second core not be able to connect to the same network as the first?

Are both chip antenna or the one not working is u.fl without an external antenna?

The other way is to use usb to enter the wifi credentials.

Look at under ‘connect over usb’

Thanks @kennethlimcp. And they are both chip antenna.

Okay, both cores are online and breathing cyan!!! Apparently letting it sit for a couple of hours worked magic and now they’re both connected to the cloud.

Thanks again for the help.


Strange, but glad they’re working!