Spark core sudden death?

Hello everyone
I just received the spark, and after trying the test codes I tried to re-flash the tinker app, while doing so the led flashed red a few seconds and the turned off completely.
From that point on it hasn’t got on again, I’ve measured the 3.3v outputs so the power seems to be working fine, but without the leds I can’t know if the rest of the thing is working
What could have gone wrong? Is there anything I can do?

Can you try performing a factory reset?

that solved the problem thank you! but i’m still confused about what happened, how can i avoid this?

1 Like

The firmware flashed with OTA, despite having CRC checks to the packets received became corrupted and the core was unable to run the code.

Sometimes it’s due to long latency as well but it has been happening very rarely ever since the improvements for OTA was made.

With the new firmware flashed into your code, it shouldn’t probably resolve itself. :wink:

@llidanxD, if you have Spark-cli installed, you can use spark flash --factory tinker to replace the factory reset firmware.

If you happen to have an old white core maybe. :smiley:

1 Like

I am not an expert as I am new here but I flashed my core with a bad library file and it did something very similar to yours.

I had to do a factory reset to get it working again