Device is not connected

My core, which has been working until the past couple of days, has stopped working completely. I’ve gone through several resets, flashing cc3000 firmware, trying deep update, and everything seems like it should work. I have ‘breathing cyan’ back, it has an IP on my network, but I get:

$ spark core add <id>
Claiming core <id>
Failed to claim core, server said  [ 'Device is not connected' ]
Potentially unhandled rejection [1] {"ok":false,"errors":["Device is not connected"]} (WARNING: non-Error used)

Any suggestions?

Hi @ebarendt

When someone has a problem where it was working for a while and then suddenly seems to stop, I always recommend that you check your access token and see if it has expired.

There were problems with the Spark cloud a few nights ago but I think they are all resolved now.

I was not using the spark-cli before today when I tried to debug, so when I logged in, it got a different token than I got through the web UI before.

Oh, and I can’t even ping the core’s IP from my laptop.

Just an FYI–answering ping’s autonomously was removed by TI in the last TI CC3000 patch to make room for other bug fixes, so that’s not really an indication that anything is wrong.

I’m having the same issue. Was working fine,then last night it stopped. I did a reset and managed to load the wifi credentials through cli but it wont claim it. I’m getting the same error “device is not connected”. somehow it detects the device for credentials but not for claiming. I also tried claiming through the ide and still nothing. I contacted Joe @spark but we have not resolved it yet.

I"ll update if any progress is made


have your core been claimed already? spark list will give you a list of cores tied to your account.

If it has been claimed already, simply add in or remove Wifi credentials and you are good to go.

Let me know if you need more help etc. I’ll be having around the forum. :wink:

I can’t claim mine because it says “Device is not connected”, even though it’s breathing cyan. Sounds like he has the same problem - ok for connecting, can’t claim it.

@ebarendt, same question to you, has it been claimed before? :smile:

There might be a slight delay for the API to respond to the request but give or take 10 seconds should be fine.

1.) You can claim using spark core add using Spark-cli OR

2.) Use the Web IDE to add a core via the Cores tab

It has been, yes, but is no longer on my account. And any attempt to spark core add or spark cloud claim or claim via the web UI fails.

You might be logon to an incorrect account then?

If it has been claimed, it will not disappear from the list. Sometimes, it’s just a typo in the login email. :smiley:

Try this:"

The access token can be found under settings tab on the Web IDE

I think this is a good question for @Dave since there have been other cloud issues lately.

@ebarendt some folks have had this problem when they accidentally end up with two Spark accounts with two different email addresses or a typo in their email address. [@kennethlimcp beat me to it!]

1 Like

@kennethlimcp I mistakenly ran spark core remove earlier when trying everything I could to get back to a blank slate. The web UI, which I have used to program the core and previously worked, also does not list the core, so I don’t think it’s because I have logged into a different account.

Cool! Can you try the browser url option I suggested?<device-id>?access_token=<token> gives

  error: "Permission Denied",
  info: "I didn't recognize that core name or ID, try opening<token>"

Which is different than if I access with a wrong token, so I know my access token is good.<token> gives:

[ ]

I had it claimed for a week or so. When it stopped responding last night ( after many failed attempts to restart and clearing wifi credentials), I removed the core from my account and did a factory reset in hopes that a fresh start would make it work, no such luck. I also tried claiming through ide but it can’t find the core.

Its strange, I can save wifi credebtials (over usb and smart config), it breathes a nice healthy cyan color but it wont claim it.

“error”: “Permission Denied”,
“info”: "I didn’t recognize that core name or ID, try opening

tried the url you posted, and this is what I got.

@KingRex, can you try adding the core via the Web Ide?

I will try on my side and see if it works as well


I removed my core from my account and added it again.

@ebarendt, what happens when you add the core id via Web IDE?

@KingRex can you try adding via the Web IDE?

Sorry guys for the inconvenience! It shouldn’t be cubersome but we probably missed some steps. :wink:

tried that, “could not claim core”

new development, now I cant even get it to connect to wifi anymore. the cli says eveything is ok and that “spark <3 you!” I dont believe it. The led is blinking green really fast for about 10-15 seconds then it turns cyan for 1 second then goes back to panic green. keeps repeating over an over

kennethlimcp, thank you for your help.