[Solved] Can't connect Spark Core to Spark Cloud + can't claim core

A little background: My programming experience is limited to the HTML I taught myself in high school and my understanding of device communications is nil. Absolute newbie but willing to learn.

Kevin the support dude has been really good about helping me troubleshoot but unfortunately nothing has worked. Below are the steps I’ve tried and their outcomes.

  1. Over USB – Connected core to computer, loaded PuTTY,
    update settings (COM3, 9600, 8, none, 1), selected W, input credentials ->
    Blinking Green

  2. Using Android APP – USB blinking Blue, added credentials
    to App, Blinked green for split second then went to yellow-red-cyan cycle
    (previous attempts have gone on like this for hours with no connection [i.e. breathing cyan]). After 2 min or so App
    times out and the core keeps cycling.

  3. Spark CLI – switched to DFU mode, loaded DFU Util 0.8,
    reflashed all the firmware updates (factory tinker, CC3000, usb tinker), core
    started blinking blue, typed ‘spark setup’, confirmed credentials, Potentially
    unhandled rejection [2] timed out, held down mode until it reset (still
    blinking blue), entered WiFi credentials -> Blinking Green [core does not

I’ve installed OpenSSL but haven’t used it and I’m not sure how it relates to the CLI. I figured since all of the commands are working I must not need it.

Any advice is appreciated.
Thanks Spark Community!

Hey @1000ways,

great detailed description of your problem here! Should be able to help :smile:

yellow-red-cyan --> Means that somehow your core is having bad keys issues

To resolve this, place the core in DFU mode and use the command spark keys doctor CORE_ID

If you need the core id, place the core in Listening mode(blinking blue) by holding on the MODE button for 4 seconds. On Spark-cli, use spark identify and you will see the core id.

1 Like

Thanks @Kennethlimcp, that was exactly what was wrong and how to fix it. The one thing I’ll add (for anyone else who has this issue) was that the DFU-util files had to be in the openssl\bin folder in order to work.

Can’t tell you how psyched I am

1 Like