Pulsing white, red-green LED lit - dead Core?

I just received my new Spark Core and was able to get it connected to wifi via USB and use tinker to control the built in LED. Everything went downhill when I connected a 6v DC 300mA power supply to the VIN and GRD pins.

At first I thought it was flashing cyan, but then I figured out it was actually flashing white. I almost burnt myself trying to push the mode button, so I unplugged it from the power supply and let it cool down.

I then plugged it in via USB and got a pulsing white LED. I then tried the reset procedure, but ended up with the same result, so I tried to reload all of the firmware. I am able to get the unit into DFU mode. Running “spark flash --factory tinker” completed successfully and the unit remained in DFU mode. However when I ran “spark flash --usb cc3000”, the unit started flashing magenta and never left that state. After about 10 minutes I unplugged it. I tried the same process but ran --factory tinker and --usb tinker first (again, the unit stayed in DFU mode), and then tried --usb cc300, but to the same result.

I subsequently tried using dfu-util with the provided firmware to no avail. Now if I put it back into DFU, and run “spark flash --usb cc3000”, the unit will momentarily show magenta, and then go into a state where the red and blue LED’s are flashing.

Now when I power on the device via USB I get about 3 flashes of a white light, and then it goes into a state where is flashing with both the green and red LED’s dimly. The USB connector is still getting extremely hot to the point where I can’t touch it for more than a few seconds.

Is my Core fried, or is there any other way I can recover it?

Not sure, but you could test some things.

First, the docs state that the voltage regulator should be powered max. 6.0V (abs. max. as datasheet states 6.5V), could it be that your power supply pushed this limit a bit? Try measuring the effective voltage and quality (filtered 6V or pulsed DC?).
When you got your Core connected via USB (only shortly ;-)), try measuring the voltage at the 3V3 pin.
If you have a reliable 3V3 power source (don’t exceed) try powering your Core that way to see if it does behave better - try factory resetting then.
If it works powered via 3V3 you might be lucky and just need to resolder (if it just desoldered itself) or replace the voltage regulator.

Others might have some more/better advise, but this you could tick off, till one of the pros join in :wink:

@ScruffR’s advice is dead on. Often I have seen cheap “6V DC” wall warts deliver unstable and poorly regulated voltage, often over the rated voltage or with ripple noise pushing the voltage well above 6V. As such, you may have damaged the 3.3V onboard regulator. The good news is, if you have soldering experience, it can be replaced.

One thing @ScruffR left out is if you do not measure 3.3V at the 3.3V pin when powering with USB then, if you have a GOOD 3.3v power supply, you could try to power the core via the 3.3V pin directly. You must have a solid 3.3V at 300ma (or more) or else don’t try it. :smiley:

@peekay123 :wink:

But your extra info - 3V3 pin and 300mA - I didn’t mention :+1:

@ScruffR, I must have had a brain fart for sure :stuck_out_tongue_winking_eye: You, sir, rock as usual :wink:

1 Like

Thanks for the advice, will check when I get home. In the event the regulator is bad, should I expect to see a higher voltage at the 3.3 pin? Is there any way to confirm if I’ve done any permanent damage without first replacing the regulator?

@sberkovitz, typically if the regulator is blown you will not see anything near 3.3V on the pin. Many, if not most members reporting similar issues were able to replace the regulator and recover their Cores :smile:

Thanks @ScruffR and @peekay123. The “6v” supply, which I measured a few days ago at 5.5v, is now putting out 9.25v! Yikes! The regulator is outputting 2.2v at the 3.3v pin, so sounds like it is fried. I will pickup a replacement part, along with a better power supply tomorrow and hope for the best.

Thanks again.


Just wanted to report that after replacing voltage regulator and reflashing the device, I have a working core again!