Photon Setup - Particle Android app freezes while displaying "Connecting to Photon"


I bought 2 Photons, one through and I successfully could do the setup. The second Photon I bought directly from Particle together with the Photon kit, which unfortunately does not want me to setup successfully.

After clicking “Ready” the Photon appears in the list. I click “Photon-ULTN”, a message “Connecting to Photon” appears and after a few seconds the rotating icon freezes, see screenshot.

I’m using a Nexus 5 running on Android 6.0.1.

I also added the relevant parts from logcat, see below

What can I do to fix this problem?

@Tukan From the error you are getting it seems like there is something going on, perhaps @ido has some insights to this. I am running the same flavor of droid on the Nexus 6 and I was not able to reproduce this issue with my photons and the app.

In the meantime, Have you tried configuring the photon via other means? ( i.e. Particle CLI, another mobile device, serial connection)

1 Like

thank you for trying to help!

I now tried Particle CLI, as far as I can see, same result, see below

> I have detected a Photon connected via USB.
? Would you like to continue with this one? Yes
! The Photon supports secure Wi-Fi setup. We'll try that first.

! PROTIP: Wireless setup of Photons works like a wizard!
! PROTIP: We will automagically change the Wi-Fi network to which your computer is connected.
! PROTIP: You will lose your connection to the internet periodically.

> No nearby Photons detected. Try the `particle.js help` command for more information.
? Would you like to wait and monitor for Photons entering setup mode? No

> Ok, bye! Don't forget `particle.js help` if you're stuck! <3


I probably also should have mentioned, that the LED next to D7 is blue (see red arrow).

That LED was off in the first Photon, where I could setup successfully.

Now reading Photon led d7 stuck high and AVOID factory reset - What to do with unexpected LED behavior on a Photon
I will try some more suggestions from there…


Since you have CLI, make sure you have nodeJS >= 4.0.0 (node -v), then do the following

npm update -g particle-cli
// connect via USB and put your Photon in DFU mode (yellow blinking)
particle update
// still DFU Mode
particle flash --usb tinker
// clear WiFi (on running device hold SETUP >10sec till rapid blue)
// listening mode (blue blinking)
particle serial wifi
// listening mode again
particle serial identify
// copy returned device id
// reset device wait till breathing cyan or magenta
particle add device <insert copied device ID>

thank you @ScruffR

yes, I have nodejs 4.4.0. I followed your suggestion

npm update -g particle-cli
// connect via USB and put your Photon in DFU mode (yellow blinking)
particle update

but after particle update I get Error code: 1

C:\Dev\nodejs>particle update *
!!! There was an error trying execute DFU utilities.

!!! For help with installing DFU Utilities, please see:

!!! You may also find our community forums helpful:

> Error code: 1

after reading this

To use the local flash and key features you’ll also need to install dfu-util, and openssl. They are freely available and open-source, and there are installers and binaries for most major platforms.

Do I have to install dfu_util and openssl first? Which means, I have to follow these steps Tutorial: Installing DFU-Driver on Windows [24 Feb 2015] or is there a newer tutorial?


I’m not sure if you need openSSL for the above (since I happened to have that already on my machines) but dfu-util you definetly need to download (it’s no real install, just put it in a folder and add that to your search path).

But if you want to gain access to all the CLI features (including key doctor) the openSSL would be good to have too.

After installing dfu_util and following your steps I now could successfully setup the device.
Thank you again.


App freezing for me at exact same place on Android 6.

My app is also continuously freezing in that same place. I would prefer to not have to manually set the up the photon. What gives?

Running Nexus 6 with android 6.0.1. Particle v 1.6.3