Android App - Particle Setup Problems

Hi,

I’ve tried using the Android up to set-up both of my Photons and it appears to fail in a consistent manner.

I know at least one of the Photons works as I briefly managed to get it connected using the CLI and sending data before System.sleep() destroyed the connection and a bug in the CLI has since prevented me getting it going again. The Android app has however never managed to set-up the Photon properly.

Doing one Photon at a time with it flashing blue, using a Samsung S5, android version 5.0.1, I’m UK based and AP is using WPA2-AES.

Open the App.
Add Photon.
At “Time to set up your photon” click Ready.
Photon is listed e.g. "Photon-4NP5"
Click Photon.
“Connecting to Photon”.

After this two different things appear to happen based on if this is first time or if they have been through the process once.

Very first time around I get prompted with a list of AP’s to connect to. I select mine, enter the password and wait, and wait, and look at the big red ! with Error underneath it.

Second time around:
Notice Android says connected to Photon-4NP5
Wait
Notice Android says connected to … (my normal AP).
See screen saying Error Please try running setup again after resetting your Photon and putting it back in blinking blue listen mode if needed".

Reset Photon.
It’s blinking blue.
Press Ready on Android App.
Click Photon
"Connecting to Photon".
Select WiFi Network

This time around it says

Your photon is connecting to with Spinner.

I wait, and wait and wait

And bid red ! Error “Setup process couldn’t configure the Wi-Fi credentials for your Photon” (FYI - I have two different AP’s, I’ve tried both - different SSID/passwords, I’ve tried this repeatedly time and time again and it fails constantly so I hope I’ve ruled out potential issues upstream of the keyboard).

Try again after reset and I don’t get past the connect to the Photon this time.

Sadly between this and issues with the CLI I’m totally stuck with unusable Cores and Photons. I know they work on my WiFi as I have some cores that are connected and functional but I was only able to connect them with the CLI previously.

Thanks,

Steve.

Ping @ido

Try this: [Howto] Setup photon if docs step fail

Also, could you elaborate a bit further on the issues you’re seeing regarding the CLI? I’m sure @nexxy would be interested in hearing those.
You can also use a serial terminal to configure wifi credentials if needed, might be a decent alternative?


I see you’ve already done so :wink:

1 Like

@Moors7 Yes well spotted, I did them separately as both CLI and App have different issues but neither worked for me.

I did manage to get the Photon’s going using the serial method, the Core took a bit of extra nudging but that’s now operational as well.

I should have just started with the serial option as it’s actually easier than all the trouble of the CLI (install node + install cli + don’t run in VS2013 cmd line as serial breaks + all that) and the Android app has never connected up a core/photon. When my next batch of 6 Photons arrive I think I’ll just head straight for the Arduino serial thing!

It’s such a shame as I love these little devices, when their running they are great and so easy to publish data with but the initial set-up has been troublesome from day 1 and lets it down.

Glad you’ve got it working! Do note that the tools are under continuous development, and should constantly get better. That said, if all else fails, luckily there’s still the option of using something as simple as the Serial terminal :smile:

I had very similar issues. (Samsung Note II)

Try this:

  • Switch off the “Smart network switch” option at the top of the Wifi screen in Android Settings

Then it will connect like a dream. It did for me,

1 Like

Same problem…spinner gets stuck on claiming a photon. Android 6.