CLI problems - Core and Photon Setup


I’m having lots of problems getting my Core and Photons set-up, a lot of which appear to be down to the CLI and some probably due to the WiFi gods.

FYI: The Android app repeatedly fails and I’ve never had any success with it on-boarding new cores. I tried the Photons with it but they failed also, hence I am forced to fall back to the CLI which is not failing me as well.

On my laptop:

  1. With nothing connected to the USB ports the CLI reports a Core is connected and did I want to configure that. I have no other COM ports on the laptop and nothing at all connected to USB and even all cores/photons powered down that it might pick-up via WiFi.

  2. With a Photon connected to the laptop the CLI still reports the Core connected, when I say No to use the Core it exits, I have no way to configure the Photon.

  3. First time around I was able to connect to the Photon, that was before I connected a core and install the Core driver, since it has seen the core it has defaulted to always reporting a core connected (I note in the code for the CLI it checks the device is a core to start with so that is understandable).

On my desktop PC:

  1. Before upgrading the CLI I had been able to use the CLI to configure my core (note that these are old kick starter era cores), at the time I had jumped through various hoops to upgrade the firmware and had then been able to set-up the WiFi. However when I try to do that now (I presume a new version of the CLI as it’s been some time) I get an error setting the security on the core.

    Attempting to configure Wi_Fi on COM18
    I said: w
    Serial Said: SSID:
    I said: xxxxxx (my SSID)

    Serial said: xxxxxx (my SSID)
    timed out on Security 0=unsecured, 1=WEP, 2=WPA, 3=WPA2
    timed out on Spark <3 you!
    Something went wrong Serial prompt timed out - Please try restarting your device

    ! Something went wrong
    ! Serial prompt timed out - please try restarting your device
    Potentially unhandled rejection [2] Serial prompt timed out - …

  2. Still on the PC I am unable to use the CLI to set the WiFi credentials of my Photons (I have tried both of the ones I have). All I get is a screen full of “Obtaining device information…”

I know the Cores work, I have two that are up and running and connected to the WiFi, I’ve had Photon #1 connected to the Wifi at once stage and sending data but after using System.sleep() I’ve been unable to recover the Photo and get it back onto the WiFi. The core was also working until my dumb coding mistake.

Could you please help me get these back onto my WiFi! All I wanted to do was make a simple humidity meter, but currently I have 3 unusable devices.



I believe i gave you some guide in the other thread. Do try to minimize cross posting or it’s hard to support issues. :wink:


Thanks for your replies.

I opened two different posts because it’s about two different topics, this one the problems with the CLI, the other problems with the App. Yes both fail to connect but in different ways but they both have additional problems as well (e.g. CLI sees ghost core/photons which blocks its use). I intentionally separated them out to create a clean break to hopefully help the developers resolve the individual problems rather than combining them all into one big confusing “nothing works” post.

I was hoping to not have to fall back to the old serial method although to be honest I think it’s the only way that has really ever worked for me, having both CLI and App it would be nice if those worked and again, figured I’d post my findings in the hope that they may help to resolve those issues so other customers may not suffer the frustration like I have.

Yes all in listening mode.

For the drivers I used device manager, selected the device (I think it showed up as a com port of some kind - a Teensy if I remember correctly). Then update drivers -> point to folder where I downloaded particle drivers. Clearly it’s not a driver issue as the CLI does at-least pick up the device (and the old ones as well! - although interestingly only on my laptop)

Trying with the serial terminal.

One thing to note: With the Arduino terminal you need to to use the “Carriage return” option when entering SSID/Password but not the “i” or “w” commands which makes using that a little bit extra messy, it might be helpful to mention that in your summary for Adruino terminal users as the enter key effectively pushes the send button rather than the enter key value being sent.

Set the details for my core, it appears to think it got connected to the WiFi but is now showing solid purplish colour and not showing as connected in the build environment. It’s possible that it’s a firmware issue as I did a factory reset and it may have taken a very very old firmware on the device rather than the updated stuff.

I managed to update both Photons using serial terminal and they appear to have connected correctly (although build environment showed the first as connected even when it was powered down which is impressive).

As a side note: A work around for the issue with the CLI where it always picks up the spark core/other devices even when not connected:

Device Manager.
View->Show Hidden Devices.
Find the devices in Ports that are not connected and uninstall.
CLI then only sees the one that is connected so should allow you to work with that.

Obviously it would be nice if it let you select the device but somebody needs to replace the TODO with some code to do that.

Anyway, Core still busted by the looks of it. Both Photons now back and connected. The serial terminal method worked for them, it’s a shame when the simple connection like that works so well and yet the CLI and App both fall over in a big heap in their own different ways (like I say, hence the two separate posts, both have separate issues that need fixing).

Obviously CLI (and app) still not working but at least I’ve got my humidity measurements working now!