Plethora of Problems [Solved]

So my situation here is a little bit unique and I am having a hard time getting my core to work. I recently talked my dad into getting a photon to help his business and we had no problems setting it up. Now I wanted to get my Core out and start messing with it. I haven’t messed with this thing for a few years, but I loved it when I worked with it.

So initially, I tried to do the regular setup. However, I was unable to find it under wifi like the site was telling me. It was flashing blue signifying it was looking for wifi. Could not diagnose the problem.

Whipped out the app and tried to connect to it from there. After a bit of the regular led flashing colors signifying that it was connecting to wifi, it went to breathing cyan. Success! Or actually not since the app said that it could not find any cores. Hmm…

No problem. I will just download CLI and do a fresh install. CLI crashes on startup and I can’t even use the darn thing in offline mode.

I have done several factory resets and can reliably get breathing cyan, but I cannot connect to anything. I am guessing I am going to have some outdated firmware that may be causing the problem since I haven’t messed with it since uni, but I can’t fix that problem if I cannot connect to it. Any ideas? I love these things but this one is going to give me an aneurysm.

Where did you read that? If you looked at the Photon setup procedure you need to know that the Core’s uses a rather different route than the Photon.

How did you do that on which OS?

What version CLI on what OS?

With a Core that wasn’t used for such a long time, an update to the factory reset firmware would be advisable too.

particle flash --factory tinker
particle flash --usb cc3000
particle flash --usb tinker

https://docs.particle.io/support/troubleshooting/connection-help/core/#deep-update-for-the-core

BTW, my personal stand towards the Core (and I have a few) is that it was a nice kit to open up the IoT world back then, but now I’m not using any of them for tinkering anymore. The ones that do their job faithfully are nicely plodding on but once one of them loses its mind I’d just replace it for a Photon.

  1. The website tells you to set up cores as photons.

  2. Windows. Didn’t have CLI before and followed the instructions.

  3. Current off of the website and Windows again.

I’ll try some more stuff along those lines.

I was afraid that the cores were too outdated… I might just have to bite the bullet and get a new photon or something… Oh well… TO THE TROUBLE SHOOTING LAB!!!

Bite the bullet, the Photon is rock solid.

I happily threw my Cores in the trash.

There are different ways to do that in Windows, which one did you chose?
Did you use the Windows CLI Installer or the “Advanced Install”?

The Core’s can be a bit finicky and Photon is definetly the better choice - but I’d not necessarily bin the Cores. They can still be used for less demanding stuff. Especially when used offline, they are also running solid.

BTW, “Windows” doesn’t really tell the whole story :wink: (Windows 3.1 … Windows 10, 32 or 64 bit, …)

I used the installer. I wasn’t trying to be masochistic or add another way to screw up an already finicky system. It ran perfectly, but never opened and when I tried opening it manually, it just crashed.

:frowning:
It somehow got me through my thermodynamics lab. Maybe I should just mount it in a shadow box and put it with my other engineering stuff. Oh the memories… Late nights in the lab, people disproving the Second Law of Thermodynamics, discovering systems that had negative efficiency, students accidentally making pipe bombs… Good times…

What do you mean by that? How do you open CLI?
I guess you opened a cmd or powershell console window and in there executed / ran the CLI via a particle .... command, right?

I have tried stuff via cmd and I have tried digging around in the files. Let’s say that I am a complete Luddite and messed up the commands. How should I go about this? What commands are needed?

As said before

You may want to first call particle login to also get access to the cloud dependent commands.

If you are not sure whether you may have inadvertently messed up the source files, you can always uninstall CLI and reinstall.
But before you unistall, try npm uninstall -g particle-cli just to make sure you haven’t got another installation quietly sitting on your system already.

Okay. CLI is working. I have had a successful flash in DFU mode. Now what?

On a side note, It is really late here so I am sorry if I am missing obvious things.

If you have executed all these commands successfully your Core should behave normal again.
When you visit console.particle.io/devices and select your Core you should be able to see the Tinker functions to try whether the device responds (e.g. digitalWrite D7,HIGH)

First of all, I would like to thank you for your help. You have done an excellent job. Unfortunately, I am REALLY tired now and I am having a hard time concentrating. I figured that while I was getting almost live help, I might as well take advantage of it.

Now for the fuzzy stuff. It is not showing up under devices and the core is in wifi listening mode flashing blue and I have no idea what to do from here.

1 Like

That’s probably due to some previous factory reset or the CC3000 update which has wiped the stored WiFi credentials.
You can reapply the WiFi credentials via particle serial wifi

When you are up again I’ll probably still be round (for the next 12-14 hours) to assist.

Okay. You are dealing with zombie MadTrumpeter now. I will definitely go to sleep after posting this (you stopped me just now). I was able to connect it via the particle command. Breathing cyan and it seems to be working. However, it is not showing up under the console devices. I tried possibly claiming under build, but needed the hex identifier. It has been a long time since I have messed with this thing. I ran the particle identify command and got a serial timeout error. Good Night and Thank You!

Don’t let me stop you again, but was the device blinking blue while you did particle identify?

It was not blinking. It was breathing cyan. Went ahead and tried DFU mode (flashing yellow) because why not. Serial port timeout error on both.

(Sorry, IRL stuff got in the way.)

When the device is in DFU Mode (blinking yellow) a serial timeout is inevitable - in that mode is no serial interface exposed via USB.
It needs to be in Listening Mode (blinking blue - not breathing cyan) for particle identify

OMG it works. Just for anyone that ever finds this discussion and to remove any suspense from the situation, here is what happened. I had the device on an old univeristy account that I somehow still received forwarded email from. Needed to transfer the device to my new account (that I thought was my old one). I was only able to figure this out by trying to claim the device on my new account via particle identify. BEEP BOOP BOOP and after three years, Sparky is alive again and I was able to verify it via a program. THANK YOU!

SPARKY LIVES

2 Likes