Particle photon not connecting through app

I received my particle photon a few days ago, finally got to hook it up but I had connect it through the CLI, once connected, the RGB LED is breathing cyan, but I still cannot connect through the app.

Did you claim it to your account?

1 Like

What exactly do you mean by “cannot connect through the app”?
Can you not use the Tinker features of the app with your device or do you expect to see the Photon’s SoftAP?
Can you Tinker via CLI?

No, As simple as it sounds, ive been on the forums for a few hours and have seen a few references to this but it didn’t sound mandatory, my plan was to play with it at my shop and get it working then go in depth at home, but I will go claim it now.

1 Like

I tried doing “particle setup”

I have detected a photon connected via USB
Would you like to continue with this one? Yes

No nearby photons connected.

I have connected via “particle serial wifi” and the photon breathes cyan, but anything else gets me no response

Try putting it in listening mode and issue particle identify. Note the ID you get. Then reset the Photon, so it’s breathing cyan again, and then issue particle device add [ID].

Trying this now, it seems I was able to claim the device ok, but the app is still not finding it on the network

Can you see it on your account in the Build IDE?

The app never finds my device on the network, and a “particle setup” command gives me errors.

The device is in the build IDE and shows as being connected

Then did you make sure the app has the same account as the build IDE? If so, the device should show up in there. Make sure you’re using the Particle Photon app, and not the older Spark Core app.

I got it, I uninstalled and reinstalled the core app, and reflashed tinker onto the photon. I’m still getting errors when issuing “particle setup” but I guess it isn’t important at this point.

Not sure if that’s the cause of the issues, but you should avoid using the Core App for the Photon. It’s okay the other way around, but since the Photon is newer, the Core app might be problematic.

Sorry not the core app, I can’t getc that anymore, I re installed the spark app. It worked fine at my shop but won’t connect at my house.